Cấu hình RouterA:
Current configuration : 1253 bytes
!
version 12.2
!
hostname RouterA
!
ip subnet-zero
!
crypto isakmp policy 1
hash md5
authentication pre-share
crypto isakmp keepalive 30 5
!
crypto isakmp peer address 14.38.69.71
set aggressive-mode password cisco123
set aggressive-mode client-endpoint ipv4-address 14.38.69.70
!
crypto ipsec transform-set myset esp-3des esp-md5-hmac
!
crypto map mymap 1 ipsec-isakmp
set peer 14.38.69.71
set transform-set myset
match address 100
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0/0
ip address 14.38.69.70 255.255.0.0
half-duplex
crypto map mymap
!
!
!
ip classless
ip route 0.0.0.0 0.0.0.0 14.38.69.71
ip http server
!
access-list 100 permit ip 1.1.1.0 0.0.0.255 2.2.2.0 0.0.0.255
!
!
!
End
Cấu hình Router B
Current configuration : 1147 bytes
!
version 12.2
!
hostname RouterB
!
ip subnet-zero
!
crypto isakmp policy 1
hash md5
authentication pre-share
crypto isakmp key cisco123 address 14.38.69.70
crypto isakmp keepalive 30 5
!
crypto ipsec transform-set myset esp-3des esp-md5-hmac
!
crypto dynamic-map mymap 10
set transform-set myset
!
crypto map mainmap 1 ipsec-isakmp dynamic mymap
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 14.38.69.71 255.255.0.0
duplex auto
speed auto
crypto map mainmap
!
interface Serial0/0
no ip address
shutdown
no fair-queue
!
!
ip classless
ip route 0.0.0.0 0.0.0.0 14.38.69.70
no ip http server
!
!
End