Tạo các cổng loopback và đặt địa chỉ theo bảng sau:
Thiết bị |
Cổng |
IP/subnetmask |
R1 |
Loopback11 |
10.1.1.1/30 |
R1 |
Loopback15 |
10.1.1.5/30 |
R1 |
Loopback19 |
10.1.1.9/30 |
R2 |
Loopback21 |
10.1.2.1/30 |
R2 |
Loopback25 |
10.1.2.5/30 |
R2 |
Loopback29 |
10.1.2.9/30 |
R3 |
Loopback31 |
10.1.3.1/30 |
R3 |
Loopback35 |
10.1.3.5/30 |
R3 |
Loopback39 |
10.1.3.9/30 |
R1(config)# interface Loopback 11
R1(config-if)# ip address 10.1.1.1 255.255.255.252
R1(config-if)# exit
R1(config)# interface Loopback 15
R1(config-if)# ip address 10.1.1.5 255.255.255.252
R1(config-if)# exit
R1(config)# interface Loopback 19
R1(config-if)# ip address 10.1.1.9 255.255.255.252
R1(config-if)# exit
!
R2(config)# interface Loopback 21
R2(config-if)# ip address 10.1.2.1 255.255.255.252
R2(config-if)# exit
R2(config)# interface Loopback 25
R2(config-if)# ip address 10.1.2.5 255.255.255.252
R2(config-if)# exit
R2(config)# interface Loopback 29
R2(config-if)# ip address 10.1.2.9 255.255.255.252
R2(config-if)# exit
!
R3(config)# interface Loopback 31
R3(config-if)# ip address 10.1.3.1 255.255.255.252
R3(config-if)# exit
R3(config)# interface Loopback 35
R3(config-if)# ip address 10.1.3.5 255.255.255.252
R3(config-if)# exit
R3(config)# interface Loopback 39
R3(config-if)# ip address 10.1.3.9 255.255.255.252
R3(config-if)# exit
Đặt địa chỉ cho các cổng serial theo sơ đồ trên, cài clock rate là 64 kbps và cấu hình giá trị băng thông là 64 kbps:
R1(config)# interface Serial 0/0/0
R1(config-if)# description R1-->R2
R1(config-if)# clock rate 64000
R1(config-if)# bandwidth 64
R1(config-if)# ip address 10.1.102.1 255.255.255.248
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface Serial 0/0/1
R1(config-if)# description R1-->R3
R1(config-if)# bandwidth 64
R1(config-if)# ip address 10.1.103.1 255.255.255.248
R1(config-if)# no shutdown
R1(config-if)# exit
R2(config)# interface Serial 0/0/0
R2(config-if)# description R2-->R1
R2(config-if)# bandwidth 64
R2(config-if)# ip address 10.1.102.2 255.255.255.248
R2(config-if)# no shutdown
R2(config-if)# exit
R2(config)# interface Serial 0/0/1
R2(config-if)# description R2-->R3
R2(config-if)# clock rate 64000
R2(config-if)# bandwidth 64
R2(config-if)# ip address 10.1.203.2 255.255.255.248
R2(config-if)# no shutdown
R2(config-if)# exit
R3(config)# interface Serial 0/0/0
R3(config-if)# description R3-->R1
R3(config-if)# clock rate 64000
R3(config-if)# bandwidth 64
R3(config-if)# ip address 10.1.103.3 255.255.255.248
R3(config-if)# no shutdown
R3(config-if)# exit
R3(config)# interface Serial 0/0/1
R3(config-if)# description R3-->R2
R3(config-if)# bandwidth 64
R3(config-if)# ip address 10.1.203.3 255.255.255.248
R3(config-if)# no shutdown
R3(config-if)# exit
Cấu hình định tuyến EIGRP với AS 100 trên các router.
R1(config)# router eigrp 100
R1(config-router)# network 10.0.0.0
!
R2(config)# router eigrp 100
R2(config-router)# network 10.0.0.0
!
R3(config)# router eigrp 100
R3(config-router)# network 10.0.0.0
Sử dụng lệnh “debug ip eigrp 100” để xem EIGRP đưa các route vào bảng định tuyến sau khi các router thiết lập các mối quan hệ cận kề (adjacency).
R1#debug ip eigrp 100
R1#conf t
R1(config)# router eigrp 100
R1(config-router)# network 10.0.0.0
R1(config-router)#
*Sep 26 16:16:23.740: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.1.102.2 (Serial0/0/0) is up: new adjacency
*Sep 26 16:16:23.748: IP-EIGRP(Default-IP-Routing-Table:100): Processing incoming UPDATE packet
*Sep 26 16:16:25.748: IP-EIGRP(Default-IP-Routing-Table:100): 10.1.102.0/24 - do advertise out Serial0/0/0
*Sep 26 16:16:25.748: IP-EIGRP(Default-IP-Routing-Table:100): 10.1.103.0/29 - do advertise out Serial0/0/0
*Sep 26 16:16:25.748: IP-EIGRP(Default-IP-Routing-Table:100): Int
10.1.103.0/29 metric 40512000 - 40000000 512000
*Sep 26 16:16:25.748: IP-EIGRP(Default-IP-Routing-Table:100): 10.1.1.0/30 - do advertise out Serial0/0/0
*Sep 26 16:16:25.748: IP-EIGRP(Default-IP-Routing-Table:100): Int 10.1.1.0/30 metric 128256 - 256 128000
(đã bỏ qua một số dòng)
Kiểm tra bảng định tuyến của các router:
R1# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary,L1-IS-IS level-1, L2-IS-IS level-2
ia- IS-IS inter area,* - candidate default, U-per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 8 subnets, 3 masks
D 10.1.2.8/30 [90/40640000] via 10.1.102.2, 01:08:13, Serial0/0/0
C 10.1.1.8/30 is directly connected, Loopback19
D 10.1.2.0/30 [90/40640000] via 10.1.102.2, 01:08:13, Serial0/0/0
C 10.1.1.0/30 is directly connected, Loopback11
D 10.1.2.4/30 [90/40640000] via 10.1.102.2, 01:08:13, Serial0/0/0
C 10.1.1.4/30 is directly connected, Loopback15
C 10.1.103.0/29 is directly connected, Serial0/0/1
C 10.1.102.0/24 is directly connected, Serial0/0/0
Các router đã thiết lập được neighbor (full adjacency), bây giờ ta có thể ping thành công đến tất cả các cổng loopback của các router.
Kiểm tra các mối quan hệ láng giềng:
R1# show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.102.2 Se0/0/0 10 00:00:22 1 5000 2 0
1 10.1.103.3 Se0/0/1 13 00:04:36 24 2280 0 14
R2# show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.102.1 Se0/0/0 14 00:00:37 1 5000 1 22
1 10.1.203.3 Se0/0/1 11 00:03:29 143 2280 0 15
R3# show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 10.1.203.2 Se0/0/1 14 00:03:43 241 2280 0 18
0 10.1.103.1 Se0/0/0 14 00:05:05 38 2280 0 17
Bảng topology của EIGRP chứa tất cả các route mà router học được từ các láng giềng. Để xem bảng topology, sử dụng lệnh “show ip eigrp topology” trên mode privilege. Dưới đây là kết quả của việc sử dụng lệnh này trên router R3:
R3# show ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(10.1.3.9)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 10.1.3.8/30, 1 successors, FD is 128256
via Connected, Loopback31
P 10.1.2.8/30, 1 successors, FD is 40640000
via 10.1.203.2 (40640000/128256), Serial0/0/1
P 10.1.1.8/30, 1 successors, FD is 40640000
via 10.1.103.1 (40640000/128256), Serial0/0/0
P 10.1.2.0/30, 1 successors, FD is 40640000
via 10.1.203.2 (40640000/128256), Serial0/0/1
P 10.1.1.0/30, 1 successors, FD is 40640000
via 10.1.103.1 (40640000/128256), Serial0/0/0
P 10.1.2.4/30, 1 successors, FD is 40640000
via 10.1.203.2 (40640000/128256), Serial0/0/1
P 10.1.1.4/30, 1 successors, FD is 40640000
via 10.1.103.1 (40640000/128256), Serial0/0/0
P 10.1.103.0/29, 1 successors, FD is 40512000
via Connected, Serial0/0/0
P 10.1.102.0/29, 2 successors, FD is 41024000
via 10.1.103.1 (41024000/40512000), Serial0/0/0
via 10.1.203.2 (41024000/40512000), Serial0/0/1
P 10.1.203.0/29, 1 successors, FD is 40512000
via Connected, Serial0/0/1
Để hiểu rõ hơn kết quả xuất ở trên, ta phân tích các thông tin liệt kê tương ứng với mạng đích 10.1.102.0/29 (các dòng được đánh dấu). Ta thấy từ router R3 có hai đường đi đến mạng 10.1.102.0/29 và cả hai đường này đều có metric là 41024000 , có giá trị AD (Advertised Distance) là 40512000 nên cả hai đường này đều được coi là successor và đều được đưa vào bảng định tuyến để sử dụng làm các đường đi chính thức đến mạng 10.1.102.0/29. Có thể xem các thông tin chi tiết hơn về mạng này bằng câu lệnh:
R3# show ip eigrp topology 10.1.102.0/29
IP-EIGRP (AS 100): Topology entry for 10.1.102.0/29
State is Passive, Query origin flag is 1, 2 Successor(s), FD is 41024000
Routing Descriptor Blocks:
10.1.103.1 (Serial0/0/0), from 10.1.103.1, Send flag is 0x0
Composite metric is (41024000/40512000), Route is Internal
Vector metric:
Minimum bandwidth is 64 Kbit
Total delay is 40000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
10.1.203.2 (Serial0/0/1), from 10.1.203.2, Send flag is 0x0
Composite metric is (41024000/40512000), Route is Internal
Vector metric:
Minimum bandwidth is 64 Kbit
Total delay is 40000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
Các thông tin chi tiết hơn được liệt kê thêm:
Từ kết quả ở trên, ta thấy router R3 đi đến mạng 10.1.102.0/29 theo hai đường, một đường có next – hop 10.1.103.1 với cổng ra là serial 0/0/0, một đường có next – hop là 10.1.203.2 với cổng ra là serial 0/0/1. Router đã thực hiện cân bằng tải trên hai đường đều nhau. Để quan sát sự cân bằng tải này, ta tắt tính năng CEF trên router, thực hiện ping kiểm tra cùng với câu lệnh “debug ip eigrp packets”.
R3(config)# no ip cef
R3# debug ip packets
IP packet debugging is on
R3# ping 10.1.102.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.102.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
R3#
*Sep 26 22:07:41.943: IP: tableid=0, s=10.1.103.3 (local), d=10.1.102.1 (Serial0/0/0), routed via RIB
*Sep 26 22:07:41.943: IP: s=10.1.103.3 (local), d=10.1.102.1 (Serial0/0/0), len 100, sending
*Sep 26 22:07:41.947: IP: tableid=0, s=10.1.102.1 (Serial0/0/0), d=10.1.103.3 (Serial0/0/0), routed via RIB
*Sep 26 22:07:41.947: IP: s=10.1.102.1 (Serial0/0/0), d=10.1.103.3 (Serial0/0/0), len 100, rcvd 3
*Sep 26 22:07:41.947: IP: tableid=0, s=10.1.203.3 (local), d=10.1.102.1 (Serial0/0/1), routed via RIB
*Sep 26 22:07:41.947: IP: s=10.1.203.3 (local), d=10.1.102.1 (Serial0/0/1), len 100, sending
*Sep 26 22:07:41.947: IP: tableid=0, s=10.1.102.1 (Serial0/0/1), d=10.1.203.3 (Serial0/0/1), routed via RIB
*Sep 26 22:07:41.951: IP: s=10.1.102.1 (Serial0/0/1), d=10.1.203.3 (Serial0/0/1), len 100, rcvd 3
*Sep 26 22:07:41.951: IP: tableid=0, s=10.1.103.3 (local), d=10.1.102.1 (Serial0/0/0), routed via RIB
*Sep 26 22:07:41.951: IP: s=10.1.103.3 (local), d=10.1.102.1 (Serial0/0/0), len 100, sending
*Sep 26 22:07:41.951: IP: tableid=0, s=10.1.102.1 (Serial0/0/0), d=10.1.103.3 (Serial0/0/0), routed via RIB
*Sep 26 22:07:41.951: IP: s=10.1.102.1 (Serial0/0/0), d=10.1.103.3 (Serial0/0/0), len 100, rcvd 3
*Sep 26 22:07:41.951: IP: tableid=0, s=10.1.203.3 (local), d=10.1.102.1 (Serial0/0/1), routed via RIB
*Sep 26 22:07:41.951: IP: s=10.1.203.3 (local), d=10.1.102.1 (Serial0/0/1), len 100, sending
*Sep 26 22:07:41.955: IP: tableid=0, s=10.1.102.1 (Serial0/0/1), d=10.1.203.3 (Serial0/0/1), routed via RIB
*Sep 26 22:07:41.955: IP: s=10.1.102.1 (Serial0/0/1), d=10.1.203.3 (Serial0/0/1), len 100, rcvd 3
*Sep 26 22:07:41.955: IP: tableid=0, s=10.1.103.3 (local), d=10.1.102.1 (Serial0/0/0), routed via RIB
*Sep 26 22:07:41.955: IP: s=10.1.103.3 (local), d=10.1.102.1 (Serial0/0/0), len 100, sending
*Sep 26 22:07:41.959: IP: tableid=0, s=10.1.102.1 (Serial0/0/0), d=10.1.103.3 (Serial0/0/0), routed via RIB
*Sep 26 22:07:41.959: IP: s=10.1.102.1 (Serial0/0/0), d=10.1.103.3 (Serial0/0/0), len 100, rcvd 3
Như hiển thị ở trên, EIGRP cân bằng tải trên cổng S0/0/0 và S0/0/1.
Lệnh “show ip eigrp topology” chỉ hiển thị các route successor và feasible successor trong bảng topology. Để quan sát được các route khác, ta phải sử dụng thêm tham số “all-links” trong câu lệnh này. Tham số “all-links” đi kèm với câu lệnh “show ip eigrp topology” sẽ hiển thị toàn bộ bảng topology kể cả các route không phải successor và feasible successor.
R3# show ip eigrp topology all-links
IP-EIGRP Topology Table for AS(100)/ID(10.1.3.9)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 10.1.3.8/30, 1 successors, FD is 128256, serno 3
via Connected, Loopback31
P 10.1.2.8/30, 1 successors, FD is 40640000, serno 24
via 10.1.203.2 (40640000/128256), Serial0/0/1
via 10.1.103.1 (41152000/40640000), Serial0/0/0
P 10.1.1.8/30, 1 successors, FD is 40640000, serno 17
via 10.1.103.1 (40640000/128256), Serial0/0/0
via 10.1.203.2 (41152000/40640000), Serial0/0/1
P 10.1.2.0/30, 1 successors, FD is 40640000, serno 22
via 10.1.203.2 (40640000/128256), Serial0/0/1
via 10.1.103.1 (41152000/40640000), Serial0/0/0
P 10.1.1.0/30, 1 successors, FD is 40640000, serno 15
via 10.1.103.1 (40640000/128256), Serial0/0/0
via 10.1.203.2 (41152000/40640000), Serial0/0/1
P 10.1.2.4/30, 1 successors, FD is 40640000, serno 23
via 10.1.203.2 (40640000/128256), Serial0/0/1
via 10.1.103.1 (41152000/40640000), Serial0/0/0
P 10.1.1.4/30, 1 successors, FD is 40640000, serno 16
via 10.1.103.1 (40640000/128256), Serial0/0/0
via 10.1.203.2 (41152000/40640000), Serial0/0/1
P 10.1.103.0/29, 1 successors, FD is 40512000, serno 13
via Connected, Serial0/0/0
P 10.1.102.0/29, 2 successors, FD is 41024000, serno 42
via 10.1.103.1 (41024000/40512000), Serial0/0/0
via 10.1.203.2 (41024000/40512000), Serial0/0/1
P 10.1.203.0/29, 1 successors, FD is 40512000, serno 12
via Connected, Serial0/0/1
Sử dụng lệnh “show ip eigrp topology 10.1.2.0/30” , để hiển thị tất cả các đường đi đến mạng 10.1.2.0/30 từ router R3 (kể cả những đường không phải successor và feasible successor).
R3# show ip eigrp topology 10.1.2.0/30
IP-EIGRP (AS 100): Topology entry for 10.1.2.0/30
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 40640000
Routing Descriptor Blocks:
10.1.203.2 (Serial0/0/1), from 10.1.203.2, Send flag is 0x0
Composite metric is (40640000/128256), Route is Internal
Vector metric:
Minimum bandwidth is 64 Kbit
Total delay is 25000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
10.1.103.1 (Serial0/0/0), from 10.1.103.1, Send flag is 0x0
Composite metric is (41152000/40640000), Route is Internal
Vector metric:
Minimum bandwidth is 64 Kbit
Total delay is 45000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 2
Thực hiện lệnh “show ip eigrp topology 10.1.2.0/30” để xem thông tin về các route đi đến mạng 10.1.2.0/30.
R3# show ip eigrp topology 10.1.2.0/30
IP-EIGRP (AS 100): Topology entry for 10.1.2.0/30
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 4064000
Routing Descriptor Blocks:
10.1.203.2 (Serial0/0/1), from 10.1.203.2, Send flag is 0x0
Composite metric is (40640000/128256), Route is Internal
Vector metric:
Minimum bandwidth is 64 Kbit
Total delay is 25000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
10.1.103.1 (Serial0/0/0), from 10.1.103.1, Send flag is 0x0
Composite metric is (41152000/40640000), Route is Internal
Vector metric:
Minimum bandwidth is 64 Kbit
Total delay is 45000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 2
Ta thấy có hai đường để đi đến mạng 10.1.2.0, một đường được chọn làm successor, tuy nhiên đường còn lại không được chọn làm feasible successor vì có giá trị AD bằng giá trị distance của đường successor (40640000). Vì tính năng cân bằng tải trên những đường không đều nhau chỉ có thể thực hiện giữa successor route và các feasible successor route nên ta không thể triển khai tính năng này trong trường hợp đi đến mạng 10.1.2.0 ở trên. Để khắc phục điều này, ta cần hiệu chỉnh để đường thứ hai trở thành feasible successor.
Đổi băng thông của các cổng serial thích hợp trên các router thành 128 kbps.
R1(config)#interface serial 0/0/0
R1(config-if)#bandwidth 128
R1(config-if)#clock rate 128000
R1(config-if)#interface serial 0/0/1
R1(config-if)#bandwidth 128
!
R2(config)#interface serial 0/0/0
R2(config-if)#bandwidth 128
!
R3(config)#interface serial 0/0/0
R3(config-if)#clock rate 128000
R3(config-if)#bandwidth 128
Gõ lệnh “show ip eigrp topology 10.1.2.0/30” trên R3, ta thấy đã có sự thay đổi:
R3#show ip eigrp topology 10.1.2.0/30
IP-EIGRP (AS 1): Topology entry for 10.1.2.0/30
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2297856
Routing Descriptor Blocks:
10.1.103.1 (Serial0/0/0), from 10.1.103.1, Send flag is 0x0
Composite metric is (20642560/156160), Route is Internal
Vector metric:
Minimum bandwidth is 128 Kbit
Total delay is 25100 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 2
10.1.203.2 (Serial0/0/1), from 10.1.203.2, Send flag is 0x0
Composite metric is (40640000/128256), Route is Internal
Vector metric:
Minimum bandwidth is 64 Kbit
Total delay is 25000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
Đường thứ hai đã trở thành feasible successor.
Trước khi thực hiện cân băng tải, sử dụng lệnh “show ip route eigrp”:
R3#sh ip route eigrp
10.0.0.0/8 is variably subnetted, 13 subnets, 2 masks
D 10.1.2.8/30 [90/20642560] via 10.1.103.1, 00:01:26, Serial0/0/0
D 10.1.1.8/30 [90/20640000] via 10.1.103.1, 00:01:26, Serial0/0/0
D 10.1.2.0/30 [90/20642560] via 10.1.103.1, 00:01:26, Serial0/0/0
D 10.1.1.0/30 [90/20640000] via 10.1.103.1, 00:01:26, Serial0/0/0
D 10.1.2.4/30 [90/20642560] via 10.1.103.1, 00:01:26, Serial0/0/0
D 10.1.1.4/30 [90/20640000] via 10.1.103.1, 00:01:26, Serial0/0/0
D 10.1.102.0/29 [90/21024000] via 10.1.103.1, 00:01:26, Serial0/0/0
D 10.1.200.0/29 [90/20514560] via 10.1.103.1, 00:01:26, Serial0/0/0
Chạy lệnh “debug ip eigrp 100” trên R3 để quan sát sự thay đổi đường đi. Tiếp theo, trong chế độ config-router của R3, dùng lệnh “variance 2”. Lúc này vì 2xFDsuccessor > FDfeasible successor nên cân bằng tải được thực hiện trên cả hai đường.
R3# debug ip eigrp 100
IP-EIGRP Route Events debugging is on
R3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#router eigrp 100
R3(config-router)#variance 2
R3(config-router)#
*Sep 26 23:52:35.875: IP-EIGRP(Default-IP-Routing-Table:100): 10.1.3.8/30
routing table not updated thru 10.1.203.2
*Sep 26 23:52:35.875: IP-EIGRP(Default-IP-Routing-Table:100): route installed
for 10.1.2.8 ()
*Sep 26 23:52:35.875: IP-EIGRP(Default-IP-Routing-Table:100): route installed
for 10.1.2.8 ()
*Sep 26 23:52:35.875: IP-EIGRP(Default-IP-Routing-Table:100): route installed
for 10.1.1.8 ()
*Sep 26 23:52:35.875: IP-EIGRP(Default-IP-Routing-Table:100): route installed
for 10.1.1.8 ()
*Sep 26 23:52:35.875: IP-EIGRP(Default-IP-Routing-Table:100): 10.1.3.0/30
routing table not updated thru 10.1.203.2
*Sep 26 23:52:35.875: IP-EIGRP(Default-IP-Routing-Table:100): route installed
for 10.1.2.0 ()
*Sep 26 23:52:35.879: IP-EIGRP(Default-IP-Routing-Table:100): route installed
for 10.1.2.0 ()
(đã bỏ qua một số dòng)
Quan sát lại bảng định tuyến sau khi đã hiệu chỉnh variance:
R3#show ip route
(đã bỏ qua một số dòng)
D 10.1.2.8/30 [90/40640000] via 10.1.203.2, 00:00:12, Serial0/0/1
[90/20642560] via 10.1.103.1, 00:00:12, Serial0/0/0
D 10.1.1.8/30 [90/40642560] via 10.1.203.2, 00:00:12, Serial0/0/1
[90/20640000] via 10.1.103.1, 00:00:12, Serial0/0/0
C 10.1.3.0/30 is directly connected, Loopback31
D 10.1.2.0/30 [90/40640000] via 10.1.203.2, 00:00:13, Serial0/0/1
[90/20642560] via 10.1.103.1, 00:00:13, Serial0/0/0
D 10.1.1.0/30 [90/40642560] via 10.1.203.2, 00:00:13, Serial0/0/1
(đã bỏ qua một số dòng)
Quan sát lại bảng topology một lần nữa:
R3# show ip eigrp topology
(đã bỏ qua một số dòng)
P 10.1.1.8/30, 1 successors, FD is 20640000
via 10.1.103.1 (20640000/128256), Serial0/0/0
via 10.1.203.2 (40642560/156160), Serial0/0/1
P 10.1.3.0/30, 1 successors, FD is 128256
via Connected, Loopback31
P 10.1.2.0/30, 1 successors, FD is 20642560
via 10.1.103.1 (20642560/156160), Serial0/0/0
via 10.1.203.2 (40640000/128256), Serial0/0/1
P 10.1.1.0/30, 1 successors, FD is 20640000
via 10.1.103.1 (20640000/128256), Serial0/0/0
via 10.1.203.2 (40642560/156160), Serial0/0/1
Cuối cùng, kiểm tra lại vấn đề cân bằng tải bằng cách sử dụng câu lệnh “debug ip packet” kèm theo lệnh ping với tham số repeat. Để lọc các thông tin hiển thị trong câu lệnh debug ta sử dụng thêm access-list:
R3(config)# access-list 100 permit icmp any any echo
R3(config)# end
R3# debug ip packet 100
IP packet debugging is on for access list 100
R3# ping 10.1.2.1 repeat 250
Type escape sequence to abort.
Sending 250, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
*Sep 27 00:50:54.231: IP: tableid=0, s=10.1.103.3 (local), d=10.1.2.1 (Serial0/0/0), routed via RIB
*Sep 27 00:50:54.231: IP: s=10.1.103.3 (local), d=10.1.2.1 (Serial0/0/0), len 100, sending
*Sep 27 00:50:54.247: IP: tableid=0, s=10.1.103.3 (local), d=10.1.2.1 (Serial0/0/0), routed via RIB
*Sep 27 00:50:54.247: IP: s=10.1.103.3 (local), d=10.1.2.1 (Serial0/0/0), len 100, sending
*Sep 27 00:50:54.263: IP: tableid=0, s=10.1.103.3 (local), d=10.1.2.1 (
!
(đã bỏ qua một số dòng)
!
*Sep 27 00:50:55.423: IP: tableid=0, s=10.1.203.3 (local), d=10.1.2.1 (Serial0/0/1), routed via RIB
*Sep 27 00:50:55.423: IP: s=10.1.203.3 (local), d=10.1.2.1 (Serial0/0/1), len 100, sending
*Sep 27 00:50:55.451: IP: tableid=0, s=10.1.203.3 (local), d=10.1.2.1 (Serial0/0/1), routed via RIB
*Sep 27 00:50:55.451: IP: s=10.1.203.3 (local), d=10.1.2.1 (Serial0/0/1), len100, sending
(đã bỏ qua một số dòng)
R1#show run
Building configuration...
!
hostname R1
!
interface Loopback11
ip address 10.1.1.1 255.255.255.252
!
interface Loopback15
ip address 10.1.1.5 255.255.255.252
!
interface Loopback19
ip address 10.1.1.9 255.255.255.252
!
interface FastEthernet0/0
ip address 10.1.200.1 255.255.255.248
no shutdown
!
interface Serial0/0/0
bandwidth 128
ip address 10.1.102.1 255.255.255.248
clock rate 128000
no shutdown
!
interface Serial0/0/1
bandwidth 128
ip address 10.1.103.1 255.255.255.248
no shutdown
!
router eigrp 100
network 10.0.0.0
auto-summary
!
end
R2#show run
Building configuration...
!
hostname R2
!
interface Loopback21
ip address 10.1.2.1 255.255.255.252
!
interface Loopback25
ip address 10.1.2.5 255.255.255.252
!
interface Loopback29
ip address 10.1.2.9 255.255.255.252
!
interface FastEthernet0/0
ip address 10.1.200.2 255.255.255.248
no shutdown
!
interface Serial0/0/0
bandwidth 128
ip address 10.1.102.2 255.255.255.248
no shutdown
!
interface Serial0/0/1
bandwidth 64
ip address 10.1.203.2 255.255.255.248
no shutdown
!
router eigrp 100
network 10.0.0.0
auto-summary
!
end
R3#show run
Building configuration...
!
hostname R3
!
interface Loopback31
ip address 10.1.3.1 255.255.255.252
!
interface Loopback35
ip address 10.1.3.5 255.255.255.252
!
interface Loopback39
ip address 10.1.3.9 255.255.255.252
!
interface Serial0/0/0
bandwidth 128
ip address 10.1.103.3 255.255.255.248
clock rate 128000
no shutdown
!
interface Serial0/0/1
bandwidth 64
ip address 10.1.203.3 255.255.255.248
clock rate 64000
no shutdown
!
interface Serial0/1/0
ip address 10.1.34.3 255.255.255.0
clock rate 2000000
no shutdown
!
router eigrp 100
variance 2
network 10.0.0.0
auto-summary
!
access-list 100 permit icmp any any echo
End