Mặc định, EIGRP không hỗ trợ mạng gián đoạn do cơ chế tự động tóm tắt các mạng con lại thành mạng chính (Auto Summarization) khi quảng bá đi. Trong bài lab này, ta sẽ tìm hiểu, phân tích và cấu hình các vấn đề sau:
!
hostname R1
!
interface Loopback0
ip address 192.168.1.1 255.255.255.0
!
interface Loopback1
ip address 10.1.1.1 255.255.255.0
!
interface Loopback2
ip address 10.1.2.1 255.255.255.0
!
interface Loopback3
ip address 10.1.3.1 255.255.255.0
!
interface Serial1/2
ip address 192.168.12.1 255.255.255.0
serial restart-delay 0
!
interface Serial1/3
ip address 192.168.13.1 255.255.255.0
serial restart-delay 0
!
hostname R2
!
interface Loopback1
ip address 10.2.1.2 255.255.255.0
!
interface Loopback2
ip address 10.2.2.2 255.255.255.0
!
interface Loopback3
ip address 10.2.3.2 255.255.255.0
!
interface Serial1/1
ip address 192.168.12.2 255.255.255.0
!
interface Serial1/3
ip address 192.168.23.2 255.255.255.0
!
!
hostname R3
!
interface Loopback1
ip address 10.3.1.3 255.255.255.0
!
interface Loopback2
ip address 10.3.2.3 255.255.255.0
!
interface Loopback3
ip address 10.3.3.3 255.255.255.0
!
interface Serial1/1
ip address 192.168.13.3 255.255.255.0
!
interface Serial1/2
ip address 192.168.23.3 255.255.255.0
R1
!
router eigrp 1
network 10.0.0.0
network 192.168.1.0
network 192.168.12.0
network 192.168.13.0
auto-summary
!
R2
!
router eigrp 1
network 10.0.0.0
network 192.168.12.0
network 192.168.13.0
auto-summary
!
R3
!
router eigrp 1
network 10.0.0.0
network 192.168.12.0
network 192.168.13.0
auto-summary
!
Bây giờ ta kiểm tra xem các router EIGRP đã thiết lập được neighbor EIGRP chưa. Dùng lệnh “show ip eigrp neighbor” để kiểm tra:
R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 192.168.13.3 Se1/3 14 00:07:16 124 744 0 17
0 192.168.12.2 Se1/2 12 00:07:39 90 540 0 12
R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 192.168.23.3 Se1/3 14 00:15:42 130 780 0 18
0 192.168.12.1 Se1/1 11 00:16:10 104 624 0 11
R3#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 192.168.23.2 Se1/2 11 00:18:43 112 672 0 14
0 192.168.13.1 Se1/1 14 00:18:47 98 588 0 12
Mô hình mạng của hình 1.3 là mạng gián đoạn. Nếu cấu hình EIGRP mặc định và để router auto – summary thì mạng không hội tụ. Kiểm tra bảng định tuyến các router sẽ thấy không học được đầy đủ và cũng không thể liên lạc được.
R1#show ip route
Gateway of last resort is not set
C 192.168.12.0/24 is directly connected, Serial1/2
C 192.168.13.0/24 is directly connected, Serial1/3
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.3.0/24 is directly connected, Loopback3
C 10.1.2.0/24 is directly connected, Loopback2
C 10.1.1.0/24 is directly connected, Loopback1
D 10.0.0.0/8 is a summary, 00:30:40, Null0
D 192.168.23.0/24 [90/2681856] via 192.168.13.3, 00:30:49, Serial1/3
[90/2681856] via 192.168.12.2, 00:30:49, Serial1/2
C 192.168.1.0/24 is directly connected, Loopback0
R1#ping 10.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.2.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#ping 10.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.3.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Kiểm tra trên router R2 và R3 cũng cho kết quả tương tự.
Để giải quyết vấn đề này, ta tắt tính năng auto-summary bằng lệnh “no auto-summary”. Cấu hình trên tất cả các router:
R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R1(config-router)#end
Cấu hình tương tự đối với router R2 và R3.
Sau khi tắt tính năng auto-summary, kiểm tra bảng định tuyến các router sẽ thấy học được đầy đủ và mạng được hội tụ.
R1#show ip route
Gateway of last resort is not set
C 192.168.12.0/24 is directly connected, Serial1/2
C 192.168.13.0/24 is directly connected, Serial1/3
10.0.0.0/24 is subnetted, 9 subnets
D 10.3.1.0 [90/2297856] via 192.168.13.3, 00:05:06, Serial1/3
C 10.1.3.0 is directly connected, Loopback3
D 10.2.1.0 [90/2297856] via 192.168.12.2, 00:05:06, Serial1/2
C 10.1.2.0 is directly connected, Loopback2
D 10.3.3.0 [90/2297856] via 192.168.13.3, 00:05:06, Serial1/3
D 10.2.2.0 [90/2297856] via 192.168.12.2, 00:05:06, Serial1/2
C 10.1.1.0 is directly connected, Loopback1
D 10.3.2.0 [90/2297856] via 192.168.13.3, 00:05:06, Serial1/3
D 10.2.3.0 [90/2297856] via 192.168.12.2, 00:05:06, Serial1/2
D 192.168.23.0/24 [90/2681856] via 192.168.13.3, 00:42:54, Serial1/3
[90/2681856] via 192.168.12.2, 00:42:54, Serial1/2
C 192.168.1.0/24 is directly connected, Loopback0
R1#ping 10.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/21/52 ms
R1#ping 10.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/46/88 ms
Mặc dù ta đã tắt tính năng auto-summary, nhưng vẫn có thể cấu hình manual-summary. Với tính năng này sẽ giúp hiệu năng mạng tối ưu hơn như: Router gửi lưu lượng thông tin định tuyến ít hơn, số route trong bảng định tuyến ít hơn, tiết kiệm được bộ nhớ và tài nguyên của router…
Những mạng được cấu hình summary trên các router như sau:
Router |
Mạng con trước khi summary |
Mạng cha sau khi summary |
R1 |
10.1.1.0/24 |
10.1.0.0/16 |
10.1.2.0/24 |
||
10.1.3.0/24 |
||
R2 |
10.2.1.0/24 |
10.2.0.0/16 |
10.2.2.0/24 |
||
10.2.3.0/24 |
||
R3 |
10.3.1.0/24 |
10.3.0.0/16 |
10.3.2.0/24 |
||
10.3.3.0/24 |
Để cấu hình manual-summary, dùng lệnh “ip summary-address eigrp” cấu hình ở mode interface của tất cả các router:
R1(config)#interface serial 1/2
R1(config-if)#ip summary-address eigrp 1 10.1.0.0 255.255.0.0
R1(config)#interface serial 1/3
R1(config-if)#ip summary-address eigrp 1 10.1.0.0 255.255.0.0
R1(config-if)#end
R2(config)#interface serial 1/1
R2(config-if)#ip summary-address eigrp 1 10.2.0.0 255.255.0.0
R2(config)#interface serial 1/3
R2(config-if)#ip summary-address eigrp 1 10.2.0.0 255.255.0.0
R2(config-if)#end
R3(config)#interface serial 1/1
R3(config-if)#ip summary-address eigrp 1 10.3.0.0 255.255.0.0
R3(config)#interface serial 1/2
R3(config-if)#ip summary-address eigrp 1 10.3.0.0 255.255.0.0
R3(config-if)#end
Sau khi cấu hình summary, kiểm tra bảng định tuyến các router ta thấy các route chi tiết đã được rút gọn lại.
R1#sh ip route
Gateway of last resort is not set
C 192.168.12.0/24 is directly connected, Serial1/2
C 192.168.13.0/24 is directly connected, Serial1/3
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
D 10.2.0.0/16 [90/2297856] via 192.168.12.2, 00:00:29, Serial1/2
C 10.1.3.0/24 is directly connected, Loopback3
D 10.3.0.0/16 [90/2297856] via 192.168.13.3, 00:00:10, Serial1/3
C 10.1.2.0/24 is directly connected, Loopback2
C 10.1.1.0/24 is directly connected, Loopback1
D 10.1.0.0/16 is a summary, 00:07:09, Null0
D 192.168.23.0/24 [90/2681856] via 192.168.13.3, 03:44:09, Serial1/3
[90/2681856] via 192.168.12.2, 03:44:09, Serial1/2
C 192.168.1.0/24 is directly connected, Loopback0
Nhìn vào bảng định tuyến ta thấy, khi cấu hình summary, router sẽ tự tạo ra 1 route tương ứng với route đã cấu hình summary đến Null0 để chống loop.
Bảng định tuyến của R2 và R3 cũng tương tự.
Để tất cả các site có thể đi Internet thì bảng định tuyến của tất cả các router cần phải có tuyến mặc định hướng ra Internet.
Trên R1, để có default route trong bảng định tuyến thì ta có thể cấu hình static default route trên R1 bằng lệnh “ip route 0.0.0.0 0.0.0.0”.
R1(config)# ip route 0.0.0.0 0.0.0.0 s1/0
Kiểm tra bảng định tuyến của R1 ta sẽ thấy có tuyến default hướng ra cổng s1/0 nối với Internet.
R1#show ip route
(đã bỏ qua một số dòng)
C 10.1.2.0/24 is directly connected, Loopback2
C 10.1.1.0/24 is directly connected, Loopback1
D 10.1.0.0/16 is a summary, 00:42:25, Null0
D 192.168.23.0/24 [90/2681856] via 192.168.13.3, 00:40:10, Serial1/3
[90/2681856] via 192.168.12.2, 00:40:10, Serial1/2
C 192.168.1.0/24 is directly connected, Loopback0
S* 0.0.0.0/0 is directly connected, Serial1/0
Các router R2 và R3 cũng có thể cấu hình tương tự như R1. Tuy nhiên để linh động hơn, thì R1 sẽ quảng bá default network vào cho R2 và R3 bằng câu lệnh “ip default-network”.
R1(config)# ip default-network 192.168.1.0
Với phương thức này, router R1 sẽ đánh dấu route 192.168.1.0 là candidate default. Các router R2 và R3 học được mạng này cũng đánh dấu là candidate default theo.
Kiểm tra bảng định tuyến trên R2 và R3.
R2#show ip route
(đã bỏ qua một số dòng)
Gateway of last resort is 192.168.12.1 to network 192.168.1.0
(đã bỏ qua một số dòng)
D 10.1.0.0/16 [90/2297856] via 192.168.12.1, 00:53:45, Serial1/1
C 192.168.23.0/24 is directly connected, Serial1/3
D* 192.168.1.0/24 [90/2297856] via 192.168.12.1, 00:04:12, Serial1/1
R3#show ip route
(đã bỏ qua một số dòng)
Gateway of last resort is 192.168.13.1 to network 192.168.1.0
(đã bỏ qua một số dòng)
C 10.3.2.0/24 is directly connected, Loopback2
D 10.1.0.0/16 [90/2297856] via 192.168.13.1, 00:55:58, Serial1/1
C 192.168.23.0/24 is directly connected, Serial1/2
D* 192.168.1.0/24 [90/2297856] via 192.168.13.1, 00:06:25, Serial1/1
R1#show running-config
!
hostname R1
!
interface Loopback0
ip address 192.168.1.1 255.255.255.0
!
interface Loopback1
ip address 10.1.1.1 255.255.255.0
!
interface Loopback2
ip address 10.1.2.1 255.255.255.0
!
interface Loopback3
ip address 10.1.3.1 255.255.255.0
!
interface Serial1/0
ip address 203.162.0.1 255.255.255.252
!
interface Serial1/2
ip address 192.168.12.1 255.255.255.0
ip summary-address eigrp 1 10.1.0.0 255.255.0.0 5
!
interface Serial1/3
ip address 192.168.13.1 255.255.255.0
ip summary-address eigrp 1 10.1.0.0 255.255.0.0 5
!
router eigrp 1
network 10.0.0.0
network 192.168.1.0
network 192.168.12.0
network 192.168.13.0
no auto-summary
!
ip default-network 192.168.1.0
ip route 0.0.0.0 0.0.0.0 Serial1/0
!
end
R2#show running-config
!
hostname R2
!
interface Loopback1
ip address 10.2.1.2 255.255.255.0
!
interface Loopback2
ip address 10.2.2.2 255.255.255.0
!
interface Loopback3
ip address 10.2.3.2 255.255.255.0
!
interface Serial1/1
ip address 192.168.12.2 255.255.255.0
ip summary-address eigrp 1 10.2.0.0 255.255.0.0 5
!
interface Serial1/3
ip address 192.168.23.2 255.255.255.0
ip summary-address eigrp 1 10.2.0.0 255.255.0.0 5
!
interface Serial1/3
ip address 192.168.23.2 255.255.255.0
ip summary-address eigrp 1 10.2.0.0 255.255.0.0 5
!
end
R3#show running-config
!
hostname R3
!
interface Loopback1
ip address 10.3.1.3 255.255.255.0
!
interface Loopback2
ip address 10.3.2.3 255.255.255.0
!
interface Loopback3
ip address 10.3.3.3 255.255.255.0
!
interface Serial1/1
ip address 192.168.13.3 255.255.255.0
ip summary-address eigrp 1 10.3.0.0 255.255.0.0 5
!
interface Serial1/2
ip address 192.168.23.3 255.255.255.0
ip summary-address eigrp 1 10.3.0.0 255.255.0.0 5
!
router eigrp 1
network 10.0.0.0
network 192.168.13.0
network 192.168.23.0
no auto-summary
!
End