HQ:
!
interface Loopback1
ip address 10.1.1.1 255.255.224.0
interface Loopback33
ip address 10.1.33.1 255.255.224.0
interface Loopback65
ip address 10.1.65.1 255.255.224.0
interface Loopback97
ip address 10.1.97.1 255.255.224.0
interface Loopback129
ip address 10.1.129.1 255.255.224.0
interface Loopback161
ip address 10.1.161.1 255.255.224.0
!
end
East:
!
interface Loopback1
ip address 10.2.1.1 255.255.224.0
interface Loopback33
ip address 10.2.33.1 255.255.224.0
interface Loopback65
ip address 10.2.65.1 255.255.224.0
interface Loopback97
ip address 10.2.97.1 255.255.224.0
interface Loopback129
ip address 10.2.129.1 255.255.224.0
interface Loopback161
ip address 10.2.161.1 255.255.224.0
!
End
West:
interface Loopback1
ip address 10.3.1.1 255.255.224.0
interface Loopback33
ip address 10.3.33.1 255.255.224.0
interface Loopback65
ip address 10.3.65.1 255.255.224.0
interface Loopback97
ip address 10.3.97.1 255.255.224.0
interface Loopback129
ip address 10.3.129.1 255.255.224.0
interface Loopback161
ip address 10.3.161.1 255.255.224.0
End
HQ# conf t
HQ(config)# interface serial 0/0/0
HQ(config-if)# ip address 172.16.124.1 255.255.255.248
HQ(config-if)# encapsulation frame-relay ietf
HQ(config-if)# no frame-relay inverse-arp
HQ(config-if)# frame-relay map ip 172.16.124.2 102 broadcast
HQ(config-if)# frame-relay map ip 172.16.124.3 103 broadcast
HQ(config-if)# no shutdown
East# conf t
East(config)# interface serial 0/0/0
East(config-if)# ip address 172.16.124.2 255.255.255.248
East(config-if)# encapsulation frame-relay ietf
East(config-if)# no frame-relay inverse-arp
East(config-if)# frame-relay map ip 172.16.124.1 201 broadcast
East(config-if)# frame-relay map ip 172.16.124.3 201 broadcast
East(config-if)# no shutdown
West# conf t
West(config)# interface serial 0/0/0
West(config-if)# ip address 172.16.124.3 255.255.255.248
West(config-if)# no frame-relay inverse-arp
West(config-if)# encapsulation frame-relay ietf
West(config-if)# frame-relay map ip 172.16.124.1 301 broadcast
West(config-if)# frame-relay map ip 172.16.124.3 301 broadcast
West(config-if)# no shutdown
Thực hiện thêm lệnh map địa chỉ IP của chính mình, trong các lệnh map này không cần sử dụng từ khóa “broadcast”:
HQ(config-if)#frame-relay map ip 172.16.124.1 102
East(config-if)#frame-relay map ip 172.16.124.2 201
West(config-if)#frame-relay map ip 172.16.124.3 301
Thực hiện các lệnh chỉnh giá trị băng thông danh định trên các cổng serial của các router:
HQ(config)# interface serial 0/0/0
HQ(config-if)# bandwidth 128
East(config)# interface serial 0/0/0
East(config-if)# bandwidth 64
West(config)# interface serial 0/0/0
West(config-if)# bandwidth 64
Mặc định, EIGRP lấy 50% băng thông danh định để gửi lưu lượng EIGRP. Ta có thể hiệu chỉnh lại tỉ lệ này bằng cách sử dụng câu lệnh “ip bandwidth-percent eigrp as_number percent”:
HQ(config-if)# ip bandwidth-percent eigrp 1 40
Tiến trình EIGRP trên router HQ sẽ sử dụng 40% băng thông danh định trên cổng serial 0/0/0 để gửi thông tin EIGRP qua cổng này.
HQ(config)# router eigrp 1
HQ(config-router)# network 10.0.0.0
HQ(config-router)# network 172.16.0.0
HQ(config-router)# no auto-summary
East(config)# router eigrp 1
East(config-router)# network 10.0.0.0
East(config-router)# network 172.16.0.0
East(config-router)# no auto-summary
West(config)# router eigrp 1
West(config-router)# network 10.0.0.0
West(config-router)# network 172.16.0.0
West(config-router)# no auto-summary
Xem bảng topology trên router West:
East# show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(172.16.124.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 10.2.0.0/19, 1 successors, FD is 128256
via Connected, Loopback1
P 10.1.0.0/19, 1 successors, FD is 40640000
via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.2.32.0/19, 1 successors, FD is 128256
via Connected, Loopback33
P 10.1.32.0/19, 1 successors, FD is 40640000
via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.2.64.0/19, 1 successors, FD is 128256
via Connected, Loopback65
P 10.1.64.0/19, 1 successors, FD is 40640000
via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.2.96.0/19, 1 successors, FD is 128256
via Connected, Loopback97
P 10.1.96.0/19, 1 successors, FD is 40640000
via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.2.128.0/19, 1 successors, FD is 128256
via Connected, Loopback129
P 10.1.128.0/19, 1 successors, FD is 40640000
via 172.16.124.1 (40640000/128256), Serial0/0/0
P 10.2.160.0/19, 1 successors, FD is 128256
via Connected, Loopback161
P 10.1.160.0/19, 1 successors, FD is 40640000
via 172.16.124.1 (40640000/128256), Serial0/0/0
P 172.16.124.0/29, 1 successors, FD is 40512000
via Connected, Serial0/0/0
East#
Ta thấy các router East và West không thấy được các mạng của nhau, đó là do tính năng chống loop split – horizon đã không cho router HQ chuyển thông tin định tuyến từ router East qua West và ngược lại. Để đảm bảo thông tin định tuyến được phân phối đầy đủ, ta cần tắt tính năng split – horizon trên cổng s0/0/0 của router HQ.
HQ(config)# interface serial 0/0/0
HQ(config-if)# no ip split-horizon eigrp 1
Xác nhận là tất cả router đã học được tất cả các route bằng lệnh “show ip route”:
HQ# show ip route
(đã bỏ qua một số dòng)
172.16.0.0/29 is subnetted, 1 subnets
C 172.16.124.0 is directly connected, Serial0/0/0
10.0.0.0/19 is subnetted, 18 subnets
D 10.2.0.0 [90/20640000] via 172.16.124.2, 00:04:36, Serial0/0/0
D 10.3.0.0 [90/20640000] via 172.16.124.3, 00:04:20, Serial0/0/0
C 10.1.0.0 is directly connected, Loopback1
D 10.2.32.0 [90/20640000] via 172.16.124.2, 00:04:36, Serial0/0/0
D 10.3.32.0 [90/20640000] via 172.16.124.3, 00:04:20, Serial0/0/0
C 10.1.32.0 is directly connected, Loopback33
D 10.2.64.0 [90/20640000] via 172.16.124.2, 00:04:37, Serial0/0/0
D 10.3.64.0 [90/20640000] via 172.16.124.3, 00:04:21, Serial0/0/0
C 10.1.64.0 is directly connected, Loopback65
D 10.2.96.0 [90/20640000] via 172.16.124.2, 00:04:37, Serial0/0/0
D 10.3.96.0 [90/20640000] via 172.16.124.3, 00:04:21, Serial0/0/0
C 10.1.96.0 is directly connected, Loopback97
D 10.2.128.0 [90/20640000] via 172.16.124.2, 00:04:37, Serial0/0/0
D 10.3.128.0 [90/20640000] via 172.16.124.3, 00:04:21, Serial0/0/0
C 10.1.128.0 is directly connected, Loopback129
D 10.2.160.0 [90/20640000] via 172.16.124.2, 00:04:37, Serial0/0/0
D 10.3.160.0 [90/20640000] via 172.16.124.3, 00:04:21, Serial0/0/0
C 10.1.160.0 is directly connected, Loopback161
East# show ip route
(đã bỏ qua một số dòng)
172.16.0.0/29 is subnetted, 1 subnets
C 172.16.124.0 is directly connected, Serial0/0/0
10.0.0.0/19 is subnetted, 18 subnets
C 10.2.0.0 is directly connected, Loopback1
D 10.3.0.0 [90/41152000] via 172.16.124.1, 00:01:31, Serial0/0/0
D 10.1.0.0 [90/40640000] via 172.16.124.1, 00:07:12, Serial0/0/0
C 10.2.32.0 is directly connected, Loopback33
D 10.3.32.0 [90/41152000] via 172.16.124.1, 00:01:31, Serial0/0/0
D 10.1.32.0 [90/40640000] via 172.16.124.1, 00:07:13, Serial0/0/0
C 10.2.64.0 is directly connected, Loopback65
D 10.3.64.0 [90/41152000] via 172.16.124.1, 00:01:32, Serial0/0/0
D 10.1.64.0 [90/40640000] via 172.16.124.1, 00:07:13, Serial0/0/0
C 10.2.96.0 is directly connected, Loopback97
D 10.3.96.0 [90/41152000] via 172.16.124.1, 00:01:32, Serial0/0/0
D 10.1.96.0 [90/40640000] via 172.16.124.1, 00:07:13, Serial0/0/0
C 10.2.128.0 is directly connected, Loopback129
D 10.3.128.0 [90/41152000] via 172.16.124.1, 00:01:32, Serial0/0/0
D 10.1.128.0 [90/40640000] via 172.16.124.1, 00:07:13, Serial0/0/0
C 10.2.160.0 is directly connected, Loopback161
D 10.3.160.0 [90/41152000] via 172.16.124.1, 00:01:32, Serial0/0/0
D 10.1.160.0 [90/40640000] via 172.16.124.1, 00:07:13, Serial0/0/0
West# show ip route
(đã bỏ qua một số dòng)
172.16.0.0/29 is subnetted, 1 subnets
C 172.16.124.0 is directly connected, Serial0/0/0
10.0.0.0/19 is subnetted, 18 subnets
D 10.2.0.0 [90/41152000] via 172.16.124.1, 00:02:00, Serial0/0/0
C 10.3.0.0 is directly connected, Loopback1
D 10.1.0.0 [90/40640000] via 172.16.124.1, 00:07:41, Serial0/0/0
D 10.2.32.0 [90/41152000] via 172.16.124.1, 00:02:00, Serial0/0/0
C 10.3.32.0 is directly connected, Loopback33
D 10.1.32.0 [90/40640000] via 172.16.124.1, 00:07:43, Serial0/0/0
D 10.2.64.0 [90/41152000] via 172.16.124.1, 00:02:01, Serial0/0/0
C 10.3.64.0 is directly connected, Loopback65
D 10.1.64.0 [90/40640000] via 172.16.124.1, 00:07:43, Serial0/0/0
D 10.2.96.0 [90/41152000] via 172.16.124.1, 00:02:01, Serial0/0/0
C 10.3.96.0 is directly connected, Loopback97
D 10.1.96.0 [90/40640000] via 172.16.124.1, 00:07:43, Serial0/0/0
D 10.2.128.0 [90/41152000] via 172.16.124.1, 00:02:01, Serial0/0/0
C 10.3.128.0 is directly connected, Loopback129
D 10.1.128.0 [90/40640000] via 172.16.124.1, 00:07:43, Serial0/0/0
D 10.2.160.0 [90/41152000] via 172.16.124.1, 00:02:01, Serial0/0/0
C 10.3.160.0 is directly connected, Loopback161
D 10.1.160.0 [90/40640000] via 172.16.124.1, 00:07:43, Serial0/0/0
Thay vì để các router chạy tiến trình tự động tìm kiếm láng giềng bằng cách gửi gói tin hello đến địa chỉ multicast 224.0.0.10, ta có thể tiến hành thiết lập quan hệ láng giềng bằng cách chỉ thẳng đến địa chỉ unicast của láng giềng:
HQ(config)# router eigrp 1
HQ(config-router)# neighbor 172.16.124.2 serial 0/0/0
HQ(config-router)# neighbor 172.16.124.3 serial 0/0/0
East(config)# router eigrp 1
East(config-router)# neighbor 172.16.124.1 serial 0/0/0
West(config)# router eigrp 1
West(config-router)# neighbor 172.16.124.1 serial 0/0/0
Kiểm tra lại bằng cách xem bảng láng giềng trên các router:
HQ# show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 172.16.124.2 Se0/0/0 153 00:00:28 65 390 0 9
0 172.16.124.3 Se0/0/0 158 00:00:28 1295 5000 0 9
East# show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.16.124.1 Se0/0/0 146 00:02:19 93 558 0 15
West# show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.16.124.1 Se0/0/0 160 00:03:00 59 354 0 15
Thực hiện tóm tắt bằng tay các mạng loopback trên mỗi router:
Router HQ:
interface Serial0/0/0
ip summary-address eigrp 1 10.1.0.0 255.255.0.0 5
Router East:
interface Serial0/0/0
ip summary-address eigrp 1 10.2.0.0 255.255.0.0 5
Router West:
interface Serial0/0/0
ip summary-address eigrp 1 10.3.0.0 255.255.0.0 5
HQ#show run
Building configuration...
!
hostname HQ
!
interface Loopback1
ip address 10.1.1.1 255.255.224.0
!
interface Loopback33
ip address 10.1.33.1 255.255.224.0
!
interface Loopback65
ip address 10.1.65.1 255.255.224.0
!
interface Loopback97
ip address 10.1.97.1 255.255.224.0
!
interface Loopback129
ip address 10.1.129.1 255.255.224.0
!
interface Loopback161
ip address 10.1.161.1 255.255.224.0
!
interface Serial0/0/0
ip address 172.16.124.1 255.255.255.248
encapsulation frame-relay ietf
no ip split-horizon eigrp 1
ip summary-address eigrp 1 10.1.0.0 255.255.0.0 5
frame-relay map ip 172.16.124.1 102
frame-relay map ip 172.16.124.2 102 broadcast
frame-relay map ip 172.16.124.3 103 broadcast
no frame-relay inverse-arp
no shutdown
!
router eigrp 1
network 10.0.0.0
network 172.16.0.0
no auto-summary
neighbor 172.16.124.3 Serial0/0/0
neighbor 172.16.124.2 Serial0/0/0
!
end
East#show run
Building configuration...
!
hostname East
!
interface Loopback1
ip address 10.2.1.1 255.255.224.0
!
interface Loopback33
ip address 10.2.33.1 255.255.224.0
!
interface Loopback65
ip address 10.2.65.1 255.255.224.0
!
interface Loopback97
ip address 10.2.97.1 255.255.224.0
!
interface Loopback129
ip address 10.2.129.1 255.255.224.0
!
interface Loopback161
ip address 10.2.161.1 255.255.224.0
!
interface Serial0/0/0
ip address 172.16.124.2 255.255.255.248
encapsulation frame-relay ietf
ip summary-address eigrp 1 10.2.0.0 255.255.0.0 5
frame-relay map ip 172.16.124.1 201 broadcast
frame-relay map ip 172.16.124.2 201
frame-relay map ip 172.16.124.3 201 broadcast
no frame-relay inverse-arp
no shutdown
!
router eigrp 1
network 10.0.0.0
network 172.16.0.0
no auto-summary
neighbor 172.16.124.1 Serial0/0/0
!
end
West#show run
Building configuration...
!
hostname West
!
interface Loopback1
ip address 10.3.1.1 255.255.224.0
!
interface Loopback33
ip address 10.3.33.1 255.255.224.0
!
interface Loopback65
ip address 10.3.65.1 255.255.224.0
!
interface Loopback97
ip address 10.3.97.1 255.255.224.0
!
interface Loopback129
ip address 10.3.129.1 255.255.224.0
!
interface Loopback161
ip address 10.3.161.1 255.255.224.0
!
interface Serial0/0/0
ip address 172.16.124.3 255.255.255.248
encapsulation frame-relay ietf
ip summary-address eigrp 1 10.3.0.0 255.255.0.0 5
frame-relay map ip 172.16.124.1 301 broadcast
frame-relay map ip 172.16.124.2 301 broadcast
frame-relay map ip 172.16.124.3 301
no frame-relay inverse-arp
frame-relay lmi-type cisco
no shutdown
!
router eigrp 1
network 10.0.0.0
network 172.16.0.0
no auto-summary
neighbor 172.16.124.1 Serial0/0/0
!
End