!
hostname LSR1
!
ip cef
!
interface Loopback0
ip address 10.10.10.101 255.255.255.255
!
interface Serial0/1
ip address 10.10.10.1 255.255.255.252
clockrate 72000
!
router ospf 100
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 0
!
R1(config)#interface s0/1
R1(config-if)# mpls ip
!
hostname LSR2
!
ip cef
!
interface Loopback0
ip address 10.10.10.102 255.255.255.255
!
interface Serial0/0
ip address 10.10.10.2 255.255.255.252
!
interface Serial0/1
ip address 10.10.10.5 255.255.255.252
!
router ospf 100
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 0
!
LSR2(config)#interface s0/0
LSR2(config-if)# mpls ip
LSR2(config)#interface s0/1
LSR2(config-if)# mpls ip
!
hostname LSR3
!
ip cef
!
interface Loopback0
ip address 10.10.10.103 255.255.255.255
!
interface Serial0/0
ip address 10.10.10.9 255.255.255.252
clockrate 72000
no fair-queue
!
interface Serial0/1
ip address 10.10.10.6 255.255.255.252
clockrate 72000
!
router ospf 100
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 0
!
LSR3(config)#interface s0/0
LSR3(config-if)# mpls ip
LSR3(config)#interface s0/1
LSR3(config-if)# mpls ip
!
hostname LSR4
!
ip cef
!
interface Loopback0
ip address 10.10.10.104 255.255.255.255
!
interface Serial0/1
ip address 10.10.10.10 255.255.255.252
!
router ospf 100
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 0
!
LSR4(config)#interface s0/1
LSR4(config-if)# mpls ip
LSR1#show ip route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O 10.10.10.8/30 [110/192] via 10.10.10.2, 00:02:58, Serial0/1
C 10.10.10.0/30 is directly connected, Serial0/1
O 10.10.10.4/30 [110/128] via 10.10.10.2, 00:02:58, Serial0/1
O 10.10.10.104/32 [110/193] via 10.10.10.2, 00:02:58, Serial0/1
O 10.10.10.102/32 [110/65] via 10.10.10.2, 00:02:58, Serial0/1
O 10.10.10.103/32 [110/129] via 10.10.10.2, 00:02:58, Serial0/1
C 10.10.10.101/32 is directly connected, Loopback0
LSR1#show ip cef
Prefix Next Hop Interface
0.0.0.0/0 drop Null0 (default route handler entry)
0.0.0.0/32 receive
10.10.10.0/30 attached Serial0/1
10.10.10.0/32 receive
10.10.10.1/32 receive
10.10.10.3/32 receive
10.10.10.4/30 10.10.10.2 Serial0/1
10.10.10.8/30 10.10.10.2 Serial0/1
10.10.10.101/32 receive
10.10.10.102/32 10.10.10.2 Serial0/1
10.10.10.103/32 10.10.10.2 Serial0/1
10.10.10.104/32 10.10.10.2 Serial0/1
224.0.0.0/4 drop
224.0.0.0/24 receive
255.255.255.255/32 receive
LSR1#show cef int s0/1
Serial0/1 is up (if_number 5)
Corresponding hwidb fast_if_number 5
Corresponding hwidb firstsw->if_number 5
Internet address is 10.10.10.1/30
ICMP redirects are always sent
Per packet load-sharing is disabled
IP unicast RPF check is disabled
Inbound access list is not set
Outbound access list is not set
IP policy routing is disabled
BGP based policy accounting is disabled
Interface is marked as point to point interface
Hardware idb is Serial0/1
Fast switching type 4, interface type 60
IP CEF switching enabled
IP CEF Fast switching turbo vector
Input fast flags 0x0, Output fast flags 0x0
ifindex 4(4)
Slot 0 Slot unit 1 Unit 1 VC -1
Transmit limit accumulator 0x0 (0x0)
IP MTU 1500
LSR1#show mpls interfaces
Interface IP Tunnel Operational
Serial0/1 Yes (tdp) No Yes
LSR1#show mpls ldp discovery
Local LDP Identifier:
10.10.10.101:0
Discovery Sources:
Interfaces:
Serial0/1 (tdp): xmit
LSR2#show cdp nei
Device ID LocalIntrfce Holdtme Capability Platform Port ID
LSR1 Ser 0/0 173 R 2610 Ser 0/1
LSR3 Ser 0/1 125 R 2610 Ser 0/1
LSR2#show ip route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O 10.10.10.8/30 [110/128] via 10.10.10.6, 00:23:26, Serial0/1
C 10.10.10.0/30 is directly connected, Serial0/0
C 10.10.10.4/30 is directly connected, Serial0/1
O 10.10.10.104/32 [110/129] via 10.10.10.6, 00:23:26, Serial0/1
C 10.10.10.102/32 is directly connected, Loopback0
O 10.10.10.103/32 [110/65] via 10.10.10.6, 00:23:26, Serial0/1
O 10.10.10.101/32 [110/65] via 10.10.10.1, 00:23:26, Serial0/0
LSR2#show ip cef
Prefix Next Hop Interface
0.0.0.0/0 drop Null0 (default route handler entry)
0.0.0.0/32 receive
10.10.10.0/30 attached Serial0/0
10.10.10.0/32 receive
10.10.10.2/32 receive
10.10.10.3/32 receive
10.10.10.4/30 attached Serial0/1
10.10.10.4/32 receive
10.10.10.5/32 receive
10.10.10.7/32 receive
10.10.10.8/30 10.10.10.6 Serial0/1
10.10.10.101/32 10.10.10.1 Serial0/0
10.10.10.102/32 receive
10.10.10.103/32 10.10.10.6 Serial0/1
10.10.10.104/32 10.10.10.6 Serial0/1
224.0.0.0/4 drop
224.0.0.0/24 receive
255.255.255.255/32 receive
LSR2#show cef int s0/0
Serial0/0 is up (if_number 4)
Corresponding hwidb fast_if_number 4
Corresponding hwidb firstsw->if_number 4
Internet address is 10.10.10.2/30
ICMP redirects are always sent
Per packet load-sharing is disabled
IP unicast RPF check is disabled
Inbound access list is not set
Outbound access list is not set
IP policy routing is disabled
BGP based policy accounting is disabled
Interface is marked as point to point interface
Hardware idb is Serial0/0
Fast switching type 4, interface type 60
IP CEF switching enabled
IP CEF Fast switching turbo vector
Input fast flags 0x0, Output fast flags 0x0
ifindex 3(3)
Slot 0 Slot unit 0 Unit 0 VC -1
Transmit limit accumulator 0x0 (0x0)
IP MTU 1500
LSR2#show cef int s0/1
Serial0/1 is up (if_number 5)
Corresponding hwidb fast_if_number 5
Corresponding hwidb firstsw->if_number 5
Internet address is 10.10.10.5/30
ICMP redirects are always sent
Per packet load-sharing is disabled
IP unicast RPF check is disabled
Inbound access list is not set
Outbound access list is not set
IP policy routing is disabled
BGP based policy accounting is disabled
Interface is marked as point to point interface
Hardware idb is Serial0/1
Fast switching type 4, interface type 60
IP CEF switching enabled
IP CEF Fast switching turbo vector
Input fast flags 0x0, Output fast flags 0x0
ifindex 4(4)
Slot 0 Slot unit 1 Unit 1 VC -1
Transmit limit accumulator 0x0 (0x0)
IP MTU 1500
LSR2#show mpls int
Interface IP Tunnel Operational
Serial0/0 Yes(ldp) No Yes
Serial0/1 Yes(ldp) No Yes
LSR2#show mpls ldp dis
Local LDP Identifier:
10.10.10.102:0
Discovery Sources:
Interfaces:
Serial0/0 (ldp): xmit
Serial0/1 (ldp): xmit/recv
LDP Id: 10.10.10.103:0
LSR2#show mpls ldp nei
Peer LDP Ident: 10.10.10.103:0; Local LDP Ident 10.10.10.102:0
TCP connection: 10.10.10.103.11010 - 10.10.10.102.646
State: Oper; Ms
LSR3#show ip route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
C 10.10.10.8/30 is directly connected, Serial0/0
O 10.10.10.0/30 [110/128] via 10.10.10.5, 00:11:19, Serial0/1
C 10.10.10.4/30 is directly connected, Serial0/1
O 10.10.10.104/32 [110/65] via 10.10.10.10, 00:11:19, Serial0/0
O 10.10.10.102/32 [110/65] via 10.10.10.5, 00:11:19, Serial0/1
C 10.10.10.103/32 is directly connected, Loopback0
O 10.10.10.101/32 [110/129] via 10.10.10.5, 00:11:19, Serial0/1
LSR3# show cdp nei
Device ID Local Intrfce Holdtme Capability Platform Port ID
LSR4 Ser 0/0 131 R 2610 Ser 0/1
LSR2 Ser 0/1 178 R 2610 Ser 0/1
LSR3#show ip cef
Prefix Next Hop Interface
0.0.0.0/0 drop Null0 (default route handler entry)
0.0.0.0/32 receive
10.10.10.0/30 10.10.10.5 Serial0/1
10.10.10.4/30 attached Serial0/1
10.10.10.4/32 receive
10.10.10.6/32 receive
10.10.10.7/32 receive
10.10.10.8/30 attached Serial0/0
10.10.10.8/32 receive
10.10.10.9/32 receive
10.10.10.11/32 receive
10.10.10.101/32 10.10.10.5 Serial0/1
10.10.10.102/32 10.10.10.5 Serial0/1
10.10.10.103/32 receive
10.10.10.104/32 10.10.10.10 Serial0/0
224.0.0.0/4 drop
224.0.0.0/24 receive
255.255.255.255/32 receive
LSR3#show cef int s0/0
Serial0/0 is up (if_number 4)
Corresponding hwidb fast_if_number 4
Corresponding hwidb firstsw->if_number 4
Internet address is 10.10.10.9/30
ICMP redirects are always sent
Per packet load-sharing is disabled
IP unicast RPF check is disabled
Inbound access list is not set
Outbound access list is not set
IP policy routing is disabled
BGP based policy accounting is disabled
Interface is marked as point to point interface
Hardware idb is Serial0/0
Fast switching type 4, interface type 60
IP CEF switching enabled
IP CEF Fast switching turbo vector
Input fast flags 0x0, Output fast flags 0x0
ifindex 3(3)
Slot 0 Slot unit 0 Unit 0 VC -1
Transmit limit accumulator 0x0 (0x0)
IP MTU 1500
LSR3#show cef int s0/1
Serial0/1 is up (if_number 5)
Corresponding hwidb fast_if_number 5
Corresponding hwidb firstsw->if_number 5
Internet address is 10.10.10.6/30
ICMP redirects are always sent
Per packet load-sharing is disabled
IP unicast RPF check is disabled
Inbound access list is not set
Outbound access list is not set
IP policy routing is disabled
BGP based policy accounting is disabled
Interface is marked as point to point interface
Hardware idb is Serial0/1
Fast switching type 4, interface type 60
IP CEF switching enabled
IP CEF Fast switching turbo vector
Input fast flags 0x0, Output fast flags 0x0
ifindex 4(4)
Slot 0 Slot unit 1 Unit 1 VC -1
Transmit limit accumulator 0x0 (0x0)
IP MTU 1500
LSR3#show mpls interfaces
Interface IP Tunnel Operational
Serial0/0 Yes(ldp) No Yes
Serial0/1 Yes(ldp) No Yes
LSR3#show mpls ldp dis
Local LDP Identifier:
10.10.10.103:0
Discovery Sources:
Interfaces:
Serial0/0 (ldp): xmit/recv
LDP Id: 10.10.10.104:0
Serial0/1 (ldp): xmit/recv
LDP Id: 10.10.10.102:0
LSR3#show mpls ldp nei
Peer LDP Ident: 10.10.10.102:0; Local LDP Ident 10.10.10.103:0
TCP connection: 10.10.10.102.646 - 10.10.10.103.11010
State: Oper; Msgs sent/rcvd: 53/49; Downstream
Up time: 00:32:45
LDP discovery sources:
Serial0/1, Src IP addr: 10.10.10.5
Addresses bound to peer LDP Ident:
10.10.10.102 10.10.10.2 10.10.10.5
Peer LDP Ident: 10.10.10.104:0; Local LDP Ident 10.10.10.103:0
TCP connection: 10.10.10.104.11004 - 10.10.10.103.646
State: Oper; Msgs sent/rcvd: 24/24; Downstream
Up time: 00:12:43
LDP discovery sources:
Serial0/0, Src IP addr: 10.10.10.10
Addresses bound to peer LDP Ident:
10.10.10.104 10.10.10.10
LSR4#show cdp nei
Device ID Local Intrfce Holdtme Capability Platform Port ID
LSR3 Ser 0/1 159 R 2610 Ser 0/0
LSR4#show ip route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
C 10.10.10.8/30 is directly connected, Serial0/1
O 10.10.10.0/30 [110/192] via 10.10.10.9, 00:13:46, Serial0/1
O 10.10.10.4/30 [110/128] via 10.10.10.9, 00:13:46, Serial0/1
C 10.10.10.104/32 is directly connected, Loopback0
O 10.10.10.102/32 [110/129] via 10.10.10.9, 00:13:46, Serial0/1
O 10.10.10.103/32 [110/65] via 10.10.10.9, 00:13:46, Serial0/1
O 10.10.10.101/32 [110/193] via 10.10.10.9, 00:13:46, Serial0/1
LSR4#show ip cef
Prefix Next Hop Interface
0.0.0.0/0 drop Null0 (default route handler entry)
0.0.0.0/32 receive
10.10.10.0/30 10.10.10.9 Serial0/1
10.10.10.4/30 10.10.10.9 Serial0/1
10.10.10.8/30 attached Serial0/1
10.10.10.8/32 receive
10.10.10.10/32 receive
10.10.10.11/32 receive
10.10.10.101/32 10.10.10.9 Serial0/1
10.10.10.102/32 10.10.10.9 Serial0/1
10.10.10.103/32 10.10.10.9 Serial0/1
10.10.10.104/32 receive
224.0.0.0/4 drop
224.0.0.0/24 receive
255.255.255.255/32 receive
LSR4#show cef int s0/1
Serial0/1 is up (if_number 5)
Corresponding hwidb fast_if_number 5
Corresponding hwidb firstsw->if_number 5
Internet address is 10.10.10.10/30
ICMP redirects are always sent
Per packet load-sharing is disabled
IP unicast RPF check is disabled
Inbound access list is not set
Outbound access list is not set
IP policy routing is disabled
BGP based policy accounting is disabled
Interface is marked as point to point interface
Hardware idb is Serial0/1
Fast switching type 4, interface type 60
IP CEF switching enabled
IP CEF Fast switching turbo vector
Input fast flags 0x0, Output fast flags 0x0
ifindex 4(4)
Slot 0 Slot unit 1 Unit 1 VC -1
Transmit limit accumulator 0x0 (0x0)
IP MTU 1500
LSR4#show mpls int
Interface IP Tunnel Operational
Serial0/1 Yes(ldp) No Yes
LSR4#show mpls ldp dis
Local LDP Identifier:
10.10.10.104:0
Discovery Sources:
Interfaces:
Serial0/1 (ldp): xmit/recv
LDP Id: 10.10.10.103:0
LSR4#show mpls ldp nei
Peer LDP Ident: 10.10.10.103:0; Local LDP Ident 10.10.10.104:0
TCP connection: 10.10.10.103.646 - 10.10.10.104.11004
State: Oper; Msgs sent/rcvd: 26/26; Downstream
Up time: 00:14:34
LDP discovery sources:
Serial0/1, Src IP addr: 10.10.10.9
Addresses bound to peer LDP Ident:
10.10.10.103 10.10.10.6 10.10.10.9