Cấu hình frame – relay trên các router và thực hiện gán địa chỉ như hình 2.4:
HQ# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
HQ(config)# interface loopback 1
HQ(config-if)# ip address 10.1.1.1 255.255.255.0
HQ(config-if)# interface serial 0/0/1
HQ(config-if)# ip address 10.1.123.1 255.255.255.0
HQ(config-if)# encapsulation frame-relay
HQ(config-if)# no frame-relay inverse-arp
HQ(config-if)# frame-relay map ip 10.1.123.1 102
HQ(config-if)# frame-relay map ip 10.1.123.2 102 broadcast
HQ(config-if)# frame-relay map ip 10.1.123.3 103 broadcast
HQ(config-if)# no shutdown
EAST# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
EAST(config)# interface loopback 2
EAST(config-if)# ip address 10.1.2.1 255.255.255.0
EAST(config-if)# interface serial 0/0/1
EAST(config-if)# ip address 10.1.123.2 255.255.255.0
EAST(config-if)# encapsulation frame-relay
EAST(config-if)# no frame-relay inverse-arp
EAST(config-if)# frame-relay map ip 10.1.123.1 201 broadcast
EAST(config-if)# frame-relay map ip 10.1.123.2 201
EAST(config-if)# frame-relay map ip 10.1.123.3 201 broadcast
EAST(config-if)# no shutdown
EAST(config-if)# interface fastethernet 0/0
EAST(config-if)# ip address 10.1.23.2 255.255.255.0
EAST(config-if)# no shutdown
WEST# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
WEST(config)# interface loopback 2
WEST(config-if)# ip address 10.1.3.1 255.255.255.0
WEST(config-if)# interface serial 0/0/1
WEST(config-if)# ip address 10.1.123.3 255.255.255.0
WEST(config-if)# encapsulation frame-relay
WEST(config-if)# no frame-relay inverse-arp
WEST(config-if)# frame-relay map ip 10.1.123.1 301 broadcast
WEST(config-if)# frame-relay map ip 10.1.123.2 301 broadcast
WEST(config-if)# frame-relay map ip 10.1.123.3 301
WEST(config-if)# no shutdown
WEST(config-if)# interface fastethernet 0/0
WEST(config-if)# ip address 10.1.23.3 255.255.255.0
WEST(config-if)# no shutdown
Kiểm tra các kết nối trực tiếp bằng lệnh “ping”.
HQ(config)# router ospf 1
HQ(config-router)# network 10.1.123.0 0.0.0.255 area 0
HQ(config-router)# network 10.1.1.0 0.0.0.255 area 0
HQ(config-router)# interface loopback 1
HQ(config-if)# ip ospf network point-to-point
EAST(config)# router ospf 1
EAST(config-router)# network 10.1.123.0 0.0.0.255 area 0
EAST(config-router)# network 10.1.2.0 0.0.0.255 area 0
EAST(config-router)# interface loopback 2
EAST(config-if)# ip ospf network point-to-point
WEST(config)# router ospf 1
WEST(config-router)# network 10.1.123.0 0.0.0.255 area 0
WEST(config-router)# network 10.1.3.0 0.0.0.255 area 0
WEST(config-router)# interface loopback 3
WEST(config-if)# ip ospf network point-to-point
Với môi trường kiểu Non – Broadcast multiaccess, ta phải chỉ ra láng giềng trên router HQ đến các router còn lại, quan hệ láng giềng không tự động thiết lập trong môi trường này.
HQ(config)# router ospf 1
HQ(config-router)# neighbor 10.1.123.2
HQ(config-router)# neighbor 10.1.123.3
EAST(config)# interface serial 0/0/1
EAST(config-if)# ip ospf priority 0
WEST(config)# interface serial 0/0/0
WEST(config-if)# ip ospf priority 0
Kiểm tra lại kết quả bằng cách sử dụng câu lệnh hiển thị các láng giềng:
HQ# show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
10.1.2.1 0 FULL/DROTHER 00:01:57 10.1.123.2 Serial0/0/1
10.1.3.1 0 FULL/DROTHER 00:01:57 10.1.123.3 Serial0/0/1
Kiểu mạng point – to – multipoint tự động thiết lập quan hệ neighbor và không bầu chọn DR, BDR, ta chỉnh lại cấu hình ban đầu cho phù hợp:
HQ(config)# router ospf 1
HQ(config-router)# no neighbor 10.1.123.2
HQ(config-router)# no neighbor 10.1.123.3
EAST(config)# interface serial 0/0/1
EAST(config-if)# no ip ospf priority 0
WEST(config)# interface serial 0/0/0
WEST(config-if)# no ip ospf priority 0
Cấu hình kiểu mạng point – to – multipoint:
HQ(config)# interface serial 0/0/1
HQ(config-if)# ip ospf network point-to-multipoint
EAST(config)# interface serial 0/0/1
EAST(config-if)# ip ospf network point-to-multipoint
WEST(config)# interface serial 0/0/0
WEST(config-if)# ip ospf network point-to-multipoint
Kiểm tra lại kết quả bằng cách sử dụng câu lệnh hiển thị các láng giềng:
HQ# show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
10.1.3.1 0 FULL/ - 00:01:34 10.1.123.3 Serial0/0/1
10.1.2.1 0 FULL/ - 00:01:45 10.1.123.2 Serial0/0/1
Quan sát bảng định tuyến của 1 outer spoke, ta thấy nó đã học được route của 2 router còn lại:
EAST# show ip route
(đã bỏ qua một số dòng)
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O 10.1.3.0/24 [110/129] via 10.1.123.1, 00:01:07, Serial0/0/1
C 10.1.2.0/24 is directly connected, Loopback2
O 10.1.1.0/24 [110/65] via 10.1.123.1, 00:01:07, Serial0/0/1
C 10.1.23.0/24 is directly connected, FastEthernet0/0
C 10.1.123.0/24 is directly connected, Serial0/0/1
O 10.1.123.1/32 [110/64] via 10.1.123.1, 00:01:07, Serial0/0/1
O 10.1.123.3/32 [110/128] via 10.1.123.1, 00:01:07, Serial0/0/1
Thực hiện lệnh “show ip ospf interface interface - id” trên các router, chúng ta thấy kiểu mạng đã trở thành point-to-multipoint.
EAST# show ip ospf interface serial 0/0/1
Serial0/0/1 is up, line protocol is up
Internet Address 10.1.123.2/24, Area 0
Process ID 1, Router ID 10.1.2.1, Network Type POINT_TO_MULTIPOINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
(đã bỏ qua một số dòng)
Cho kết nối Ethernet giữa East và West tham gia vào OSPF:
EAST(config)# router ospf 1
EAST(config-router)# network 10.1.23.0 0.0.0.255 area 0
WEST(config)# router ospf 1
WEST(config-router)# network 10.1.23.0 0.0.0.255 area 0
Xem các thông số của các cổng Ethernet OSPF bằng lệnh “show ip ospf interface”:
EAST# show ip ospf interface fastethernet 0/0
FastEthernet0/0 is up, line protocol is up
Internet Address 10.1.23.2/24, Area 0
Process ID 1, Router ID 10.1.2.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 10.1.3.1, Interface address 10.1.23.3
Backup Designated router (ID) 10.1.2.1, Interface address 10.1.23.2
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
(đã bỏ qua một số dòng)
Để các giá trị hello timer và dead timer nhỏ sẽ cập nhật nhanh được trạng thái của láng giềng, giúp cho sự hội tụ trong trường hợp có thay đổi diễn ra nhanh hơn. Tuy nhiên, nếu các giá trị này quá nhỏ, các gói tin hello được gửi ra quá thường xuyên sẽ dẫn đến hao tốn băng thông đường truyền và hao tốn tài nguyên CPU để xử lý gói tin hello.
Để thay đổi hello timer, ta sử dụng lệnh “ip ospf hello-interval seconds”, và để thay đổi giá trị dead – timer, ta sử dụng lệnh “ip ospf dead-interval seconds”. Thực hiện thay đổi các giá trị hello và dead timer trên kết nối Ethernet giữa hai router East và West thành 5 giây và 15 giây (mặc định các giá trị này là 10s, 40s).
EAST(config)# interface fastethernet 0/0
EAST(config-if)# ip ospf hello-interval 5
EAST(config-if)# ip ospf dead-interval 15
WEST(config)# interface fastethernet 0/0
WEST(config-if)# ip ospf hello-interval 5
WEST(config-if)# ip ospf dead-interval 15
Kiểm tra sự thay đổi này:
EAST# show ip ospf int f0/0
FastEthernet0/0 is up, line protocol is up
Internet Address 10.1.23.2/24, Area 0
Process ID 1, Router ID 10.1.2.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 10.1.3.1, Interface address 10.1.23.3
Backup Designated router (ID) 10.1.2.1, Interface address 10.1.23.2
Timer intervals configured, Hello 5, Dead 15, Wait 15, Retransmit 5
(đã bỏ qua một số dòng)
HQ# show run
!
hostname HQ
!
interface Loopback1
ip address 10.1.1.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0/1
ip address 10.1.123.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
frame-relay map ip 10.1.123.1 102
frame-relay map ip 10.1.123.2 102 broadcast
frame-relay map ip 10.1.123.3 103 broadcast
no frame-relay inverse-arp
no shutdown
!
router ospf 1
network 10.1.1.0 0.0.0.255 area 0
network 10.1.123.0 0.0.0.255 area 0
!
end
EAST# show run
!
hostname EAST
!
interface Loopback2
ip address 10.1.2.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 10.1.23.2 255.255.255.0
ip ospf hello-interval 5
ip ospf dead-interval 15
no shutdown
!
interface Serial0/0/1
ip address 10.1.123.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
clock rate 2000000
frame-relay map ip 10.1.123.1 201 broadcast
frame-relay map ip 10.1.123.2 201
frame-relay map ip 10.1.123.3 201 broadcast
no frame-relay inverse-arp
no shutdown
!
router ospf 1
network 10.1.2.0 0.0.0.255 area 0
network 10.1.23.0 0.0.0.255 area 0
network 10.1.123.0 0.0.0.255 area 0
!
end
WEST# show run
!
hostname WEST
!
interface Loopback3
ip address 10.1.3.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 10.1.23.3 255.255.255.0
ip ospf hello-interval 5
ip ospf dead-interval 15
no shutdown
!
interface Serial0/0/0
ip address 10.1.123.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
clock rate 2000000
frame-relay map ip 10.1.123.1 301 broadcast
frame-relay map ip 10.1.123.2 301 broadcast
frame-relay map ip 10.1.123.3 301
no frame-relay inverse-arp
no shutdown
!
router ospf 1
network 10.1.3.0 0.0.0.255 area 0
network 10.1.23.0 0.0.0.255 area 0
network 10.1.123.0 0.0.0.255 area 0
!
end
FRS# show run
!
hostname FRS
!
frame-relay switching
interface Serial0/0/0
no ip address
encapsulation frame-relay
no ip route-cache
clock rate 2000000
frame-relay intf-type dce
frame-relay route 102 interface Serial0/0/1 201
frame-relay route 103 interface Serial0/1/0 301
no shutdown
!
interface Serial0/0/1
no ip address
encapsulation frame-relay
frame-relay intf-type dce
frame-relay route 201 interface Serial0/0/0 102
no shutdown
!
interface Serial0/1/0
no ip address
encapsulation frame-relay
no ip route-cache
frame-relay intf-type dce
frame-relay route 301 interface Serial0/0/0 103
no shutdown
!
end