Trong bài lab này, cấu hình BGP để router SanJose trao đổi thông tin định tuyến với hai nhà cung cấp dịch vụ (ISP). Router SanJose thuộc AS 100 đấu nối với các ISP: ISP1 thuộc AS 200 và ISP2 thuộc AS 300.
Cấu hình xây dựng mối quan hệ láng giềng và quảng bá những mạng tương ứng:
ISP1(config)#router bgp 200
ISP1(config-router)#neighbor 10.0.0.2 remote-as 100
ISP1(config-router)#network 12.0.1.0 mask 255.255.255.0
ISP2(config)#router bgp 300
ISP2(config-router)#neighbor 172.16.0.2 remote-as 100
ISP2(config-router)#network 172.16.1.0 mask 255.255.255.0
Cấu hình SanJose thiết lập quan hệ láng giềng với ISP1 và ISP2 và quảng bá những mạng tương ứng của SanJose:
SanJose(config)#router bgp 100
SanJose(config-router)#neighbor 10.0.0.1 remote-as 200
SanJose(config-router)#neighbor 172.16.0.1 remote-as 300
SanJose(config-router)#network 192.168.0.0
SanJose(config-router)#network 192.168.1.0
Để kiểm tra các thông tin định tuyến đã cập nhật giữa các router, sử dụng lệnh “show ip route” trên SanJose:
SanJose#show ip route
(đã bỏ qua một số dòng)
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:00:03
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
12.0.0.0/24 is subnetted, 1 subnets
B 12.0.1.0 [20/0] via 10.0.0.1, 00:00:42
C 192.168.1.0/24 is directly connected, Loopback1
Ta sử dụng lệnh “show ip bgp” để kiểm tra:
SanJose#show ip bgp
BGP table version is 5, local router ID is 192.168.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 12.0.1.0/24 10.0.0.1 0 0 200 i
*> 172.16.1.0/24 172.16.0.1 0 0 300 i
*> 192.168.0.0 0.0.0.0 0 32768 i
*> 192.168.1.0 0.0.0.0 0 32768 i
Giải thích một số thông tin trong câu lệnh “show ip bgp”:
Lọc route là quá trình sử dụng một số công cụ trong BGP nhằm loại bỏ một số thông tin định tuyến trong các cập nhật định tuyến nhận được hay gửi ra từ router tương ứng.
ISP 2 sẽ đi đến mạng 12.0.1.0/24 của ISP 1 thông qua router SanJose. Điều này xảy ra là do SanJose quảng bá route thuộc ISP1 cho ISP2. Kết quả là các lưu lượng dữ liệu từ ISP2 có thể sẽ đi đến mạng 12.0.1.0/24 thông qua router SanJose. Với kết quả này, router SanJose trở thành router transit (là router trung chuyển dữ liệu giữa ISP1 và ISP2). Nhằm tránh tình huống này xảy ra, cần triển khai các bộ lọc thông tin định tuyến trên router SanJose để chỉ cho phép router SanJose quảng bá các thông tin định tuyến từ chính AS của nó (không quảng bá đi các AS khác những thông tin định tuyến học từ ISP1 và ISP2).
Ta thực hiện cấu hình router SanJose để chỉ quảng bá những mạng 192.168.0.0 và 192.168.1.0 cho hai ISP.
Để thực hiện yêu cầu này, ta dùng công cụ là distribute-list trên router SanJose.
Đầu tiên, cấu hình một access-list nhằm quy định những thông tin định tuyến nào sẽ gửi ra cho các láng giềng của mình:
SanJose(config)#access-list 1 permit 192.168.0.0 0.0.1.255
Tiếp theo, kết hợp access–list này với distribute–list như là công cụ lọc route, chú ý từ khóa “out” trong câu lệnh “neighbor A.B.C.D distribute-list 1 out”. Từ khóa này được sử dụng nhằm ảnh hưởng đến các thông tin cập nhật từ router SanJose gửi ra cho các láng giềng lân cận:
SanJose(config)#router bgp 100
SanJose(config-router)#neighbor 10.0.0.1 distribute-list 1 out
SanJose(config-router)#neighbor 172.16.0.1 distribute-list 1 out
Quay lại router SanJose và gõ lệnh “clear ip bgp *” .
SanJose(config)#router bgp 100
SanJose(config-router)#clear ip bgp *
Chờ cho đến khi mối quan hệ giữa các router đạt đến trạng thái “Established” (mất một khoảng thời gian) và sau đó sẽ kiểm tra lại bảng định tuyến của router ISP2. Ta thấy route đi đến ISP1 không còn thấy trong bảng định tuyến ISP2 nữa.
Và tương tự, route đến ISP2, tức mạng 172.16.1.0/24, sẽ không còn tồn tại trong bảng định tuyến của ISP1.
Thực hiện cấu hình các default – route chính và dự phòng. Điều này có thể được thực hiện với default static route hoặc BGP.
Ta sử dụng phương pháp default static route. Gõ lệnh “show ip route” trên router SanJose:
SanJose# show ip route
(đã bỏ qua một số dòng)
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:07:37
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
12.0.0.0/24 is subnetted, 1 subnets
B 12.0.1.0 [20/0] via 10.0.0.1, 00:07:42
C 192.168.1.0/24 is directly connected, Loopback1
Chú ý thông báo “Gateway of last resort is not set” cho biết không có default route trong bảng định tuyến. Giả định ISP1 là nhà cung cấp chính và ISP2 là đường dự phòng. Cấu hình static route để phản ánh chính sách này:
SanJose(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.1 210
SanJose(config)#ip route 0.0.0.0 0.0.0.0 172.16.0.1 220
Xác nhận default route đã được cấu hình, sử dụng “show ip route”:
SanJose# show ip route
(đã bỏ qua một số dòng)
Gateway of last resort is 10.0.0.1 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:16:34
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
12.0.0.0/24 is subnetted, 1 subnets
B 12.0.1.0 [20/0] via 10.0.0.1, 00:16:39
C 192.168.1.0/24 is directly connected, Loopback1
S* 0.0.0.0/0 [210/0] via 10.0.0.1
Kiểm tra hoạt động bằng cách tạo một loopback trên ISP1 nhưng không quảng bá mạng này cho router SanJose:
ISP1#config t
ISP1(config)#int loopback 100
ISP1(config-if)#ip address 210.210.210.1 255.255.255.0
Sử dụng lệnh “clear ip bgp 10.0.0.1” để thiết lập lại trao đổi thông tin với router 10.0.0.1:
SanJose#clear ip bgp 10.0.0.1
Chờ đến khi quan hệ BGP thiết lập lại với 10.0.0.1. Gõ “show ip route” để kiểm tra rằng chắc chắn là mạng vừa mới tạo 210.210.210.0/24 không nằm trong bảng định tuyến:
SanJose#show ip route
(đã bỏ qua một số dòng)
Gateway of last resort is 10.0.0.1 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:27:40
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
12.0.0.0/24 is subnetted, 1 subnets
B 12.0.1.0 [20/0] via 10.0.0.1, 00:27:45
C 192.168.1.0/24 is directly connected, Loopback1
S* 0.0.0.0/0 [210/0] via 10.0.0.1
Dùng lệnh ping mở rộng để ping kiểm tra từ loopback 192.168.1.1 đến 210.210.210.1:
SanJose#ping
Protocol [ip]:
Target IP address: 210.210.210.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 192.168.1.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 210.210.210.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/36 ms
Một phương pháp khác để cấu hình các đường chính và dự phòng là sử dụng lệnh “ip default-network”.
Đầu tiên, xóa các static default route đã tạo ở bước 6:
SanJose(config)#no ip route 0.0.0.0 0.0.0.0 10.0.0.1 210
SanJose(config)#no ip route 0.0.0.0 0.0.0.0 172.16.0.1 220
ISP1 đã tạo mạng 210.210.210.0/24 ở cuối bước 6. Ta quảng bá mạng này:
ISP1(config)#router bgp 200
ISP1(config-router)#network 210.210.210.0
ISP1#clear ip bgp 10.0.0.2
Cấu hình router SanJose sử dụng lệnh “ip default-network” để thiết lập lại “Gateway of Last Resort”. Kiểm tra lại rằng mạng 210.210.210.0/24 đã xuất hiện trong bảng định tuyến của router Sanjose bằng cách sử dụng câu lệnh “show ip route”.
SanJose#show ip route
(đã bỏ qua một số dòng)
Gateway of last resort is not set
B 210.210.210.0/24 [20/0] via 10.0.0.1, 00:04:51
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:21:19
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
12.0.0.0/24 is subnetted, 1 subnets
B 12.0.1.0 [20/0] via 10.0.0.1, 00:04:51
C 192.168.1.0/24 is directly connected, Loopback1
Tiếp theo, sử dụng câu lệnh “ip default-network” với mạng này:
SanJose(config)#ip default-network 210.210.210.0
Chờ một khoảng thời gian ngắn rồi kiểm tra bảng định tuyến trên router SanJose:
SanJose#show ip route
(đã bỏ qua một số dòng)
Gateway of last resort is 10.0.0.1 to network 210.210.210.0
B* 210.210.210.0/24 [20/0] via 10.0.0.1, 00:04:28
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:20:56
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
12.0.0.0/24 is subnetted, 1 subnets
B 12.0.1.0 [20/0] via 10.0.0.1, 00:04:28
C 192.168.1.0/24 is directly connected, Loopback1
Default route trên router SanJose sẽ chỉ đến ISP1. Thực hiện cấu hình thêm một default – route dự phòng nữa chỉ đến ISP2 thông qua địa chỉ đấu nối 172.16.0.1:
SanJose(config)#ip route 0.0.0.0 0.0.0.0 172.16.0.1 220
Kiểm tra lại sự xuất hiện của static default – route trên router SanJose:
SanJose#show ip route
(đã bỏ qua một số dòng)
Gateway of last resort is 10.0.0.1 to network 210.210.210.0
B* 210.210.210.0/24 [20/0] via 10.0.0.1, 00:19:17
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:35:45
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
12.0.0.0/24 is subnetted, 1 subnets
B 12.0.1.0 [20/0] via 10.0.0.1, 00:19:17
C 192.168.1.0/24 is directly connected, Loopback1
S* 0.0.0.0/0 [220/0] via 172.16.0.1
Kiểm tra tính dự phòng của route tĩnh này:
SanJose#clear ip bgp 10.0.0.1
SanJose#show ip route
(đã bỏ qua một số dòng)
Gateway of last resort is 172.16.0.1 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:45:31
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
S* 0.0.0.0/0 [220/0] via 172.16.0.1
Ta thấy, trong thời gian quan hệ BGP đang thiết lập lại, default – network 210.210.210.0/24 chưa được đưa qua, router SanJose sử dụng tạm thời default – route tĩnh. Chờ một lúc cho quan hệ BGP được tái lập với ISP1, thực hiện kiểm tra lại bảng định tuyến, ta thấy rằng default – route đã được thay thế trở lại như cũ:
SanJose#show ip route
(đã bỏ qua một số dòng)
Gateway of last resort is 10.0.0.1 to network 210.210.210.0
B* 210.210.210.0/24 [20/0] via 10.0.0.1, 00:01:03
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/0/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:46:42
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Serial0/0/0
C 192.168.0.0/24 is directly connected, Loopback0
12.0.0.0/24 is subnetted, 1 subnets
B 12.0.1.0 [20/0] via 10.0.0.1, 00:01:03
C 192.168.1.0/24 is directly connected, Loopback1
S* 0.0.0.0/0 [220/0] via 172.16.0.1
ISP1#show run
!
hostname ISP1
!
interface Loopback0
ip address 12.0.1.1 255.255.255.0
!
interface Loopback100
ip address 210.210.210.1 255.255.255.0
!
interface Serial0/0/0
ip address 10.0.0.1 255.255.255.252
clock rate 64000
no shutdown
!
router bgp 200
no synchronization
network 12.0.1.0 mask 255.255.255.0
network 210.210.210.0
neighbor 10.0.0.2 remote-as 100
no auto-summary
!
end
SanJose#show run
!
hostname SanJose
!
interface Loopback0
ip address 192.168.0.1 255.255.255.0
!
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
interface Serial0/0/0
ip address 10.0.0.2 255.255.255.252
no shutdown
!
interface Serial0/0/1
ip address 172.16.0.2 255.255.255.252
clock rate 64000
no shutdown
!
router bgp 100
no synchronization
network 192.168.0.0
network 192.168.1.0
neighbor 10.0.0.1 remote-as 200
neighbor 10.0.0.1 distribute-list 1 out
neighbor 172.16.0.1 remote-as 300
neighbor 172.16.0.1 distribute-list 1 out
no auto-summary
!
ip default-network 210.210.210.0
ip route 0.0.0.0 0.0.0.0 172.16.0.1 220
!
access-list 1 permit 192.168.0.0 0.0.1.255
!
end
ISP2#show run
!
hostname ISP2
!
interface Loopback0
ip address 172.16.1.1 255.255.255.0
!
interface Serial0/0/1
ip address 172.16.0.1 255.255.255.252
no shutdown
!
router bgp 300
no synchronization
network 172.16.1.0 mask 255.255.255.0
neighbor 172.16.0.2 remote-as 100
no auto-summary
!
End