1. Yêu cầu
2. Mô hình
3. Mô tả lab
Các thiết bị đã được lắp đặt và được nối bằng cáp FastEthernet.
Router CME1 kết nối trực tiếp tới router CME 2 bằng cáp FastEthernet.
Bước 1: Gán địa chỉ trên router CME1 và switch PoE
Sử dụng địa chỉ theo như mô hình, gán địa chỉ IP cho các cổng f0/0.10 và f0/0.20 của Router CME1.
Cấu hình router CME1:
hostname CME1
interface f0/0
description Ket noi toi switch PoE
no ip address
no shutdown
exit
interface f0/0.1
description Ket noi toi Management VLAN
encapsulation dot1q 1 native
ip address 10.1.1.254 255.255.255.0
exit
interface f0/0.10
description Ket noi toi Voice VLAN
encapsulation dot1q 10
ip address 10.1.10.254 255.255.255.0
exit
interface f0/0.20
description Ket noi toi Data VLAN
encapsulation dot1q 20
ip address 10.1.20.254 255.255.255.0
exit
line vty 0 4
privilege level 15
no login
exit
line console 0
logging synchronous
exit
no ip domain-lookup
Cấu hình switch PoE:
hostname PoE
interface vlan 1
description Dat IP quan ly cho switch
ip address 10.1.1.253 255.255.255.0
no shutdown
exit
interface f0/24
description Ket noi toi router CME1
switchport trunk encapsulation dot1q
switchport mode trunk
exit
vlan 10
exit
vlan 20
exit
interface f0/1
description Ket noi toi IP Phone 1001
switchport mode access
switchport access vlan 20
switchport voice vlan 10
spanning-tree portfast
exit
interface f0/2
description Ket noi toi IP Phone 1002
switchport mode access
switchport access vlan 20
switchport voice vlan 10
spanning-tree portfast
exit
interface f0/3
description Ket noi toi IP Phone CIPC 1003
switchport mode access
switchport access vlan 10
spanning-tree portfast
exit
line vty 0 4
privilege level 15
no login
exit
line console 0
logging synchronous
exit
no ip domain-lookup
Bước 2: Cấu hình dịch vụ DHCP trên router CME1
Trên router CME1, khởi tạo 2 dải DHCP Pool để cấp IP:
ip dhcp excluded-address 10.1.10.254
ip dhcp pool Voice
network 10.1.10.0 255.255.255.0
default-router 10.1.10.254
option 150 ip 10.1.10.254
exit
ip dhcp excluded-address 10.1.20.254
ip dhcp pool Data
network 10.1.20.0 255.255.255.0
default-router 10.1.20.254
exit
Bước 3: Cấu hình dịch vụ “telephony-service” trên router CME1
Tiến hành cấu hình dịch vụ “telephony-service” cấp số điện thoại xuống cho các IP Phone tương ứng như trong sơ đồ.
clock set 6:30:00 13 May 2015
configure terminal
telephony-service
ip source-address 10.1.10.254 port 2000
max-dn 144
max-ephones 42
create cnf-files
no auto-reg-ephone
exit
ephone-dn 1 dual-line
number 1001
exit
ephone-dn 2 dual-line
number 1002
exit
ephone-dn 3 dual-line
number 1003
exit
ephone 1
mac-address b000.b4d8.8e95
type 7965
button 1:1
codec g711ulaw
restart
exit
ephone 2
mac-address b000.b4d9.a3b1
type 7965
button 1:2
codec g711ulaw
restart
exit
ephone 3
mac-address 24b6.fd47.139e
type CIPC
button 1:3
codec g711ulaw
restart
exit
Bước 4: Cấu hình router CME2
Cấu hình router CME2 cấp số điện thoại x2001 cho IP Phone.
hostname CME2
interface f0/0
description Ket noi toi PC cai CIPC
ip address 10.2.10.254 255.255.255.0
no shutdown
exit
line vty 0 4
privilege level 15
no login
exit
line console 0
logging synchronous
exit
no ip domain-lookup
ip dhcp excluded-address 10.2.10.254
ip dhcp pool Voice
network 10.2.10.0 255.255.255.0
default-router 10.2.10.254
option 150 ip 10.2.10.254
exit
exit
clock set 6:30:00 13 May 2015
configure terminal
telephony-service
ip source-address 10.2.10.254 port 2000
max-dn 144
max-ephones 42
create cnf-files
no auto-reg-ephone
exit
ephone-dn 1 dual-line
number 2001
exit
ephone 1
mac-address 24b6.fd47.139e
type CIPC
button 1:1
codec g711ulaw
restart
exit
Bước 5: Tìm hiểu Call Legs
Trước khi tìm hiểu về Dial Peer, ta cần nắm rõ các khái niệm về dial plans và call legs. Khi một cuộc gọi call được thực hiện, voice gateway sẽ dựa vào dial peer để chuyển hướng cuộc gọi call tương tự như quá trình định tuyến sử dụng bảng “route table” trên router. Các kết nối cuộc gọi “call connections” đi vào và ra voice gateway tương ứng với các call legs. Có 2 loại kết nối connections được thực hiện tại voice gateway: dịch vụ phone service truyền thống (plain old telephone service, hoặc POTS) và VoIP.
One-Way Call Legs từ Analog Phone x2315 tới Analog Phone x337
Thông qua 4 call legs, x2315 có thể thực hiện cuộc gọi call tới x3379, để x3379 cũng có thể thực hiện cuộc gọi call tới x2315 thì cần phải có 4 call legs khác! Với mạng data network, nếu PC A có thể ping tới PC B thì chúng ta có thể giả thiết là PC B cũng có thể ping được tới PC A (trừ phi bị chặn bởi access lists) nhưng đối với hạ tầng voice networks thì điều này không còn đúng đắn nữa. x2315 có thể thực hiện cuộc gọi tới x3379 nhưng điều này không có nghĩa là x3379 cũng có thể thực hiện cuộc gọi được tới x2315.
Trong một số trường hợp, một dial peer có thể thực hiện vai trò của cả inbound call leg và outbound call legs.
Bước 6: Tìm hiểu Dial Peers
Dial peers trên hạ tầng telephony tương đương với static IP routing trên hạ tầng mạng data networks giúp chuyển hướng các cuộc gọi calls tới đúng đích destination chỉ định. Có 2 loại dial peers: POTS và VoIP.
Cấu hình dial peer loại POTS, cuộc gọi tới số x1234 sẽ được chuyển tới “port 0/1/0” trên hạ tầng mạng telephony. “Port 0/1/0” có thể là cổng giao tiếp analog interface hoặc digital interface.
dial-peer voice 15 pots
destination-pattern 1234
port 0/1/0
Cấu hình dial peer loại VOIP, cuộc gọi tới x5555678 sẽ được chuyển tới remote gateway có ip là 10.0.10.100 trên hạ tầng mạng IP-based network. Không giống như static route, session target command sẽ trỏ tới destination IP đầu cuối chứ không phải next-hop IP của router kế cận.
dial-peer voice 6 voip
destination-pattern 5555678
session target ipv4:10.0.10.100
Cả 2 loại dial peers đều bắt cầu với câu lệnh dial-peer voice tag command. Định danh “tag” là một con số dao động từ 1 tới 2147483647 (phải là duy nhất trên gateway) giúp định danh các dial peer với nhau. Thông thường, định danh “tag” sẽ trùng với chuỗi “number” trong câu lệnh “destination-pattern” để việc khắc phục sự cố sau này được thuận tiện.
Bước 7: Cấu hình Dial Peers
Tại thời điểm này, IP Phone x2001 vẫn chưa thể liên lạc được với các IP Phone x1001, x1002, x1003 và ngược lại. Ta sẽ tiến hành cấu hình “dial peer” trên router CME1 và router CME2 để IP Phone x2001 có thể liên lạc được tới x1001, x1002, x1003 và ngược lại.
Cấu hình IP giả lập trên môi trường mạng WAN tại router CME1.
interface f0/1
description Ket noi toi router CME2
ip address 1.1.1.1 255.255.255.0
no shutdown
exit
ip route 2.2.2.2 255.255.255.255 f0/1
Cấu hình IP giả lập trên môi trường mạng WAN tại router CME2.
interface f0/1
description Ket noi toi router CME1
ip address 2.2.2.2 255.255.255.0
no shutdown
exit
ip route 1.1.1.1 255.255.255.255 f0/1
Cấu hình “dial peer” trên router CME1 để IP Phone Phone x1001, x1002, x1003 có thể liên lạc được với IP Phone x2001.
dial-peer voice 2001 voip
destination-pattern 2001
session target ipv4:2.2.2.2
exit
Cấu hình “dial peer” trên router CME2 để IP Phone Phone x2001 có thể liên lạc được với IP Phone x1001, x1002, x1003.
dial-peer voice 1001 voip
destination-pattern 1001
session target ipv4:1.1.1.1
exit
dial-peer voice 1002 voip
destination-pattern 1002
session target ipv4:1.1.1.1
exit
dial-peer voice 1003 voip
destination-pattern 1001
session target ipv4:1.1.1.1
exit
Thông thường, ta có thể thiết lập các VoIP dial peer riêng biệt tương ứng với từng remote phone như trên; để giảm nhẹ gánh nặng cấu hình “dial peer” ta thường sử dụng wildcards trong “dial peer”. Với khái niệm wildcard, ta có thể cấu hình “dial peer” trên router CME2 như bên dưới. Từ IP Phone x2001 thuộc site CME2 có thể liên lạc được tới các IP Phone x1001, x1002, x1003, x1004, x1005, x1006, x1007, x1008, x1009 tại site CME1.
dial-peer voice 1000 voip
destination-pattern 100.
session target ipv4:1.1.1.1
exit
Kiểm tra cấu hình dial peer trên router CME1
CME1# show dial-peer voice summary
dial-peer hunt 0
AD PRE PASS OUT
TAG TYPE MIN OPER PREFIX DEST-PATTERN FER THRU SESS-TARGET STAT PORT
20001 pots up up 1001$ 0 50/0/1
20002 pots up up 1002$ 0 50/0/2
20003 pots up up 1003$ 0 50/0/3
2001 voip up up 2001 0 syst ipv4:2.2.2.2
CME1#
Kiểm tra cấu hình dial peer trên router CME2
CME2# show dial-peer voice summary
dial-peer hunt 0
AD PRE PASS OUT
TAG TYPE MIN OPER PREFIX DEST-PATTERN FER THRU SESS-TARGET STAT PORT KEEPALIVE
20001 pots up up 2001$ 0 50/0/1
1000 voip up up 100. 0 syst ipv4:1.1.1.1
CME2#
Trong tiến trình khắc phục sự cố hệ thống mạng, ta thường sử dụng câu lệnh “show dialplan number command”.
CME2# show dialplan number 1001
Macro Exp.: 1001
VoiceOverIpPeer1000
peer type = voice, system default peer = FALSE, information type = voice,
description = `',
tag = 1000, destination-pattern = `100.',
voice reg type = 0, corresponding tag = 0,
allow watch = FALSE
answer-address = `', preference=0,
CLID Restriction = None
CLID Network Number = `'
CLID Second Number sent
CLID Override RDNIS = disabled,
rtp-ssrc mux = system
source carrier-id = `', target carrier-id = `',
source trunk-group-label = `', target trunk-group-label = `',
numbering Type = `unknown'
group = 1000, Admin state is up, Operation state is up,
incoming called-number = `', connections/maximum = 0/unlimited,
DTMF Relay = disabled,
modem transport = system,
URI classes:
Incoming (Called) =
Incoming (Calling) =
Destination =
huntstop = disabled,
in bound application associated: 'DEFAULT'
out bound application associated: ''
dnis-map =
permission :both
incoming COR list:maximum capability
outgoing COR list:minimum requirement
outgoing LPCOR:
Translation profile (Incoming):
Translation profile (Outgoing):
incoming call blocking:
translation-profile = `'
disconnect-cause = `no-service'
advertise 0x40 capacity_update_timer 25 addrFamily 4 oldAddrFamily 4
mailbox selection policy: none
type = voip, session-target = `ipv4:1.1.1.1',
technology prefix:
settle-call = disabled
ip media DSCP = ef, ip media rsvp-pass DSCP = ef
ip media rsvp-fail DSCP = ef, ip signaling DSCP = af31,
ip video rsvp-none DSCP = af41,ip video rsvp-pass DSCP = af41
ip video rsvp-fail DSCP = af41,
ip defending Priority = 0, ip preemption priority = 0
ip policy locator voice:
ip policy locator video:
UDP checksum = disabled,
session-protocol = cisco, session-transport = system,
req-qos = best-effort, acc-qos = best-effort,
req-qos video = best-effort, acc-qos video = best-effort,
req-qos audio def bandwidth = 64, req-qos audio max bandwidth = 0,
req-qos video def bandwidth = 384, req-qos video max bandwidth = 0,
RTP dynamic payload type values: NTE = 101
Cisco: NSE=100, fax=96, fax-ack=97, dtmf=121, fax-relay=122
CAS=123, TTY=119, ClearChan=125, PCM switch over u-law=0,
A-law=8, GSMAMR-NB=117 iLBC=116, AAC-ld=114, iSAC=124
lmr_tone=0, nte_tone=0
h263+=118, h264=119
G726r16 using static payload
G726r24 using static payload
RTP comfort noise payload type = 19
fax rate = voice, payload size = 20 bytes
fax protocol = system
fax-relay ecm enable
Fax Relay ans treatment disabled
Fax Relay ans enabled
Fax Relay SG3-to-G3 Enabled (by system configuration)
fax NSF = 0xAD0051 (default)
codec = g729r8, payload size = 20 bytes,
video codec = None
voice class codec = `'
voice class sip session refresh system
voice class sip rsvp-fail-policy voice post-alert mandatory keep-alive interval 30
voice class sip rsvp-fail-policy voice post-alert optional keep-alive interval 30
voice class sip rsvp-fail-policy video post-alert mandatory keep-alive interval 30
voice class sip rsvp-fail-policy video post-alert optional keep-alive interval 30
text relay = disabled
Media Setting = forking (disabled) flow-through (global)
Expect factor = 10, Icpif = 20,
Playout Mode is set to adaptive,
Initial 60 ms, Max 1000 ms
Playout-delay Minimum mode is set to default, value 40 ms
Fax nominal 300 ms
Max Redirects = 1, signaling-type = cas,
VAD = enabled, Poor QOV Trap = disabled,
Source Interface = NONE
voice class sip url = system,
voice class sip tel-config = system,
voice class sip rel1xx = system,
tvoice class sip outbound-proxy = system,
voice class sip asserted-id = system,
voice class sip privacy = system,
voice class sip e911 = system,
voice class sip history-info = system,
voice class sip pass-thru headers = system,
voice class sip pass-thru content unsupp = system,
voice class sip pass-thru content sdp = system,
voice class sip copy-list = system,
voice class sip anat = system,
voice class sip g729 annexb-all = system,
voice class sip early-offer forced = system,
voice class sip negotiate cisco = system,
voice class sip reset timer expires 183 = system,
voice class sip block 180 = system,
voice class sip block 181 = system,
voice class sip block 183 = system,
voice class sip preloaded-route = system,
voice class sip random-contact = system,
voice class sip random-request-uri validate = system,
voice class sip call-route p-called-party-id = system,
voice class sip call-route history-info = system,
voice class sip privacy-policy send-always = system,
voice class sip privacy-policy passthru = system,
voice class sip privacy-policy strip history-info = system,
voice class sip privacy-policy strip diversion = system,
voice class sip bandwidth audio = system,
voice class sip bandwidth video = system,
voice class sip error-code-override options-keepalive failure = system,
voice class sip encap clear-channel = system,
voice class sip map resp-code 181 = system,
voice class sip bind control = system,
voice class sip bind media = system,
voice class sip registration passthrough = System
voice class sip authenticate redirecting-number = system,
redirect ip2ip = disabled
local peer = false
probe disabled,
Secure RTP: system (use the global setting)
voice class perm tag = `'
Time elapsed since last clearing of voice call statistics never
Connect Time = 0, Charged Units = 0,
Successful Calls = 1, Failed Calls = 0, Incomplete Calls = 0
Accepted Calls = 0, Refused Calls = 0,
Last Disconnect Cause is "10 ",
Last Disconnect Text is "normal call clearing (16)",
Last Setup Time = 181054.
Last Disconnect Time = 0.
Matched: 1001 Digits: 3
Target: ipv4:1.1.1.1
CME2#
Để quan sát tiến trình router lựa chọn và sử dụng “dial peers”, ta thực hiện câu lệnh “debug voip dialpeer command” (và câu lệnh “debug voip dialpeer all command” để lấy được nhiều thông tin hơn). Câu lệnh “debug voip dialpeer commands” có thể khiến cho “console buffer” bị quá tải và mất kết nối control tới router.
Link phần 2: LAB CME. Call Legs, Dial Peers, và Wildcards (Phần 2)